Install Wizard won't start

I have been trying since November to install CPF on my W2K Pro desktop, with no success. After the download is complete, I get a message to uninstall any 3rd party firewalls, and click OK. When I click OK, nothing happens, the install apparently shuts down. It does not matter whether I try to open the download from the download box, or save to file and open from that. I eventually gave up and downloaded Zone Alarm.

That worked for about a month before signature updates in my Kaspersky 6.0 (antivirus only) created conflicts with Zone Alarm, that prevented me from connecting to the internet. According to Kaspersky, they have conflicts with ZoneAlarm, but not Comodo, so I am back to sqaure 1.

I have…
Previously contacted this forum with no results
Scanned with multiple antivrus scanners from websites
Gone through extensive troubleshooting from Major Geeks to find no viruses
Downloaded utilities from Trend to completely wipe out traces of their products that were leftover from the uninstall of their products
Done a Regedit>find> PC-Cillin to find all of the registry keys that their uninstall utility did not clean out, and then set up a PsExec batch file to delete the keys that regedit could not
Tried to install from safe mode
Pulled out much of my hair
Cussed alot… ALOT

One nice thing to add to the install wizard would be some diagnostics that inform as to what troubles caused the install to head south.

In the meantime, does anyone have a clue as to what is going on???


Sorry you’ve had to cuss so much. And pull out your hair.

It sounds like you’ve cleaned out all traces of PC-Cillin. Now what about ZA? It’s well known that traces of old FW’s can conflict with new ones, so it’s good you’re looking into that.

I don’t know when/where you you got your install package for CPF, but I would advise getting a new one of the current release, version 2.4, straight from Comodo’s website: You don’t have to go through the previous registration/email process that you had to before; it’s a quick easy download.

Prior to running the install package, please be sure to turn off/deactivate/disable ALL other security software (AV, Antispy, HIPS, registry/file/process guards, etc), so that they do not cause any conflict on install.

You might also want to get a free utility like SIW, Whats Running, or Process Explorer, to verify that you don’t have any of these (or some remnant of the previous firewall) showing as active in your system. Once you’ve verified all this, then install from the new 2.4 install package.


Hey Little Mac - Thanks for the reply. To answer your question, yes, I had also contacted Zone Alarm and received instructions for wiping out all traces of their product. I had neglected to mention this as I had problems with the Comodo install wizard not starting up, prior to downloading Zone Alarm. That is why I downloaded Zone Alarm.

I have downloaded Whats running, per your suggestion, and will dig into that tonite when I have more time. One other thought that I had this morning, is that maybe something is disabled in my computer that is required for Comodo. I had a friend helping me with another issue, and he said that I did not need to have some ActiveX settings enabled. He went into the system somehow and unchecked some boxes.

I am thinking it is probably something simple like that, as I have eliminated the virus issues, and all traces of previous firewalls. Comodo is working just fine on my XP Pro based laptop, without having to jump through hoops, so unless there is a known issue with Windows 2K pro it should install just as easily.

Also, I have downloaded current versoins of CPF from the Comodo site, so that has been addressed as well.

While I am trying to learn how to use whats running, are there any basic system settings that I need to make sure are enabled to allow the download, and if so, how do I get to them to enable?

If it’s active X settings he changed, you can go in to tools/settings in your browser to change them back. There is probably a button for getting the default settings back.

Have you turned off any services in control panel/administrative tools/services?
One user said that turning on Terminal services, made it possible for him to install the firewall.

Well it’s Saturday so I have had some time to dink with the computer. I downloaded What’s Runing, per Little Mac’s suggestion, and do not show any Firewall processes running. I reset Active X to default conditions. Then I tried to download a new version straight from the Comodo web site. Now I don’t even get the message to make sure that all 3rd party firewalls are disabled - just nothing happens. Is this because I got rid of all traces that might have been initiating that prompt, but still have the issue that was causing the install wizard to shut down prior to starting?

To answer the question about what component services are shut down, I went to control panel>administrative tools>component services and the following are disabled:

Clipbook, DLWYVSS, EPQOH, Messenger, Netmeeting remote, Remote Access Auto Connection Manager, Remote Access Connection manager, Remote registry service, Routing and remote Access, RunAs Service, Telnet, XMEBQESZ, YIZ, and Z. I did not see a service named Terminal Services. How do I find it to turn it on?


Let’s get some more info (which you can use Whats Running for if you want)…

What is your System Info - Operating System, computer specs, etc?

What items are in your Startup? (if you want to grab a screenshot of that and attach to your post under Additional Options, that’s fine)

Also, if you can grab a screenshot of Whats Running under the Processes tab and attach it that would be great. We may be able to identify something that you missed. Expand the Process Name column a little bit if needed, to show the entire name.

On these screenshots if you want to crop the image down to just the info in that tab, that’s great as well. (see my attached for an example…).


[attachment deleted by admin]

Little Mac: having trouble posting a reply. Seems the snapshot file format of Whats Running is not acceptable to post, so I resaved as a notepad file and tried to send. Then I was informed that the reply was already posted (which it wasn’t), so here is a brand new reply.

I am not sure how to take screenshots of the info you want let alone crop it. Whats Running has a feature called Snapshot, which should give you all of the info you requested, although in a notepad file.

If that is not usable, please advise how to take screenshots of what you want - I’m almost as look as I dumb, but can follow directions!

[attachment deleted by admin]

Sorry about that, here’s some details on screenshots. ;D

With Whats Running open, and on the tab you want (such as processes, startup, etc), press CTRL & Print Screen keys on your keyboard. (with some computers, simply Print Screen works, with some you need both)

Now you will open an image software (if you have a scanner, it probably came with software in a bundle; something like a Photoshop type program). If you don’t have a 3rd Party software, you can use MSPaint. Go to Start/Programs/Accessories/Paint. Select Edit, then Paste (or just press CTRL and V). Now there’s your screenshot.

Then go to File, Save As, and on the save screen, change the filetype dropdown to JPEG; give it a title, and save it. Then you can attach that JPEG file to your post, just as before. Since we’re looking at Processes & Startup, you’ll have to create and attach two screenshots in this manner. Once you’ve attached the first one, you’ll note that next to the “Browse” button it says (in red text) “(more attachments).” Click that and it’ll give you another attachment box, for the 2nd screenshot.


Attached are the screenshots saved as GIF files in Paint. Paint did not give me the option of JPEG.

[attachment deleted by admin]

I will let LM help you with this, since I really don’t know why it doesn’t install.
Since you don’t get any error alerts or anything.

I can on the other hand advice you to turn off some things that autostart, that you don’t need to have. There are probably more than I suggest, but i’m not familiar with all your programs and how/when you use them.
Remember that the ones I suggest starts anyway when needed.
They only take up unnecessary resources now.
Go to start/run and type msconfig, click ok.
Go to the tab autostart.
Now uncheck:
jushed (java)
qttask (quicktime)
WZQKPICK (winzip)
Those Kodak startups…
Nero startups… (incd, nerocheck)
Adobe reader
Printer apps…
You can probably uncheck some more, so just try it and reboot.
You can always go back and check them again.
Do not turn off your Antivirus, firewall, and maybe graphics, mouse drivers, adobe gamma, wireless network… and if you use something else all the time.
Your computer will start faster/run smoother the more you turn off.
Good luck.

What’s Promon.exe? Obviously it’s monitoring something, but what does the app do?

What firewall did you have before you first tried Comodo?

Have you run a registry cleaner, like RegSeeker, to clean out defunct entries?

Is there an entry in MS Event Viewer, when you try the install? Go to Control Panel, Administrative Tools, then Event Viewer. You’ll probably want to look at Application.

Also, you might try the Microsoft Installer Cleanup Utility, available here: You’ll install and run it, and if there are any entries for your old firewall(s), use it to remove them.

Also, you should be able to deactivate the startup items that AOwl mentioned, using Whats Running.


I also noticed that you had some “IMON” styled entries as well. I’m wondering exactly what these are, as IMON.exe is a part of an AV webshield. Could be completely different and unrelated, but I just wanted to make sure…


Hey Little Mac - to answer your questions: Promon.exe is my Intel NIC console for configuring and diagnostics.

My Firewall history is as follows - I had run Trend PC-Cillin for three years, then I got CA Security suite free with purchase of a 1 gig USB flash drive. I ran CA for a couple of months but wasn’t impressed and switched over to Kaspersky 6.0. Since it was antivirus only, I wanted to use Comodo but couldn’t. I gave up on using Comodo and got Zone Alarm to download. This worked fine for a month, but then after updating Kaspersky signatures, I was completely unable to connect to the internet or get email, however Kaspersky could go out and get its updates. Kaspersky notified me that Zone Alarm was on their list of incompatible products, but Comodo is OK. So I am back to trying to get Comodo.

I have not run Regseeker, but I have contacted all of the above companies, and run their utilities that clean out traces of product left behind by the uninstall routine (why there should be ANY is a new pet peeve) Noticing that there were still traces of PC Cillin, I found a way to start a registry editor called PSEXEC that clears out even legacy keys, so I am pretty confident after searching my registry for the above providers, that I do not have any traces left.

I tried to download and install the Microsoft cleanup utility, but when trying to install, got the following error message:
Script: c:docume~1\kevin\locals~1\temp\IXP000.TMP\StartMsi.vbs
Line: 17
Char: 1
Error:permission denied
code: 800A0046
Source Microsoft VBScript runtime error

The only IMON entry I see is IMONTRAY.EXE which is an Intel monitoring of my CPU temp., fan speed etc.

Could the VB Script error above have relevance to the Comodo install problems?


Unfortunately, almost all applications leave something behind when uninstalled. I can’t give you an answer as to why that is; it’s outside of my proverbial “pay grade.” :wink: Given what you’ve gone through, you may not have a need for something like RegSeeker. On the other hand, it probably wouldn’t hurt, either, just to clean things up in general. Also you might want to recompact the registry after all the cleaning you’ve done; I’ve used RegCompact, and you can also try PageDefrag from SysInternals - both are free. You’ll want to reboot after.

As to the error message, all I can tell you (and I’m not 100% on this, even - the pay grade issue again ;D …) is that the error relates to line 17 of code in the script to start the install package. Since it’s a permissions-related error, it is possible that if you had AV running at the time, that it has a script-blocking feature that interfered. It’s also possible that you have limited privileges (ie, a User or Power User instead of Administrator) that has impacted it. If you don’t have administrative privileges on your login, you may need to alter that, or login as the default Administrator; I’m not sure on that, but it would seem to be a possibility.

Here’s my recommendation - follow the filepath the error message gave you, to the Temp folder. Open the Temp folder, Select All (Ctrl + A), and Delete. This clears out all these temp files. Reboot, make sure you turn AV off, and try to install it again.

See if that works.


Yes it could cause an error.
You can also have a problem with permissions.
Sometimes you get an error with windows installer as well. so you could try to start it manually, before you try to install anything.
Try this first before you install the cleanup utility and/or the firewall.
Go to start/control panel/administrative tools and click on services.
Find Windows installer and right click and start the process.
Now try to install, and see if it works.

You can also try to download and install VBA from Microsoft.

If you have a problem with permissions, you should download Dial-a-fix and you might need secedit too. See info on their website.
Run Dial-a-fix and go to tools and scroll down until you find "repair permissions.
You will probably need the WinXP cd you install from, to get some files. Not always, but sometimes you need it.
You can download DAF here. Download Dial-a-fix - MajorGeeks
You can also repair the windows installer with this program if you have problems with it.

If you can’t install Dial-a-fix or other programs you need to go to start/run and type regedit
Right click on HKEY_CLASSES_ROOT and choose permissions
Look in the Group or user names pane, and click on your name/account.
Next to Full Control, check the box under the Allow column.
Now in HKEY_CLASSES_ROOT, scroll down to .exe, and right click on it, and choose permissions
Make sure that it’s a check in Full Control, under the Allow column, when you highlight your name/account.

Now you can try to install dial-a-fix and repair permissions.

Well guys, I have downloaded and run Dial A Fix. The install wizrd still doesn’t start.

I can’t right click on HKEY_CLASSES_ROOT and get an option called permissions - it is not offered in my Win2K Pro OS. The whole reason for doing this was to be able to download the MS clean up utility, but Since I have pretty much done that via the individual utilities from PC=Cillin, CA, and Zone Alarm, not to mention the PSEXEC regedit, that allowed me to search for all entries and delete them, I don’t see another utility as being that useful in trying to get the Comodo install wizard to start.

I went to microsoft and downloaded a Visual basic upgrade, but there were so many options, I don’t know that it was the right one. I still can’t get the install wizard to start, and I’m not sure that I need Visual Basic to allow the Comodo wizard to start???

If I need it, is there someplace in my computer settings that a VBA box could have been unchecked, that I can recheck? Is it on my Windows 2K Pro disk, or my Office 2000 disk that I can reload?

I am the administrator, so why wouldn’t I have full permissions?

Is there a way to get a different version of Comodo that doesn’t have Comodo files listed? I am pulling at straws here, but what if my computer has been hacked and has a little routine that looks for the Comodo install files, much like a primitive virus protection looks for file names, and disables the installation before it starts?

I am really getting weary - its been 3 months of dicking with this issue, and I am no closer than when I started,with the exception of now being eligible for an Honerary IT degree!

What is the first thing that the Comodo install wizard trys to do, and what does my computer need to do to allow this??? Let’s start there, because that’s where it is failing.

The order of operations in installation would be a question for the developers, Kevin; that’s not something that I can answer, unfortunately. On that I would refer you to filing a ticket with Support -

My thought for using the MS Cleanup Utility, has to do with references to installations remaining on the computer. I have had issues with that in the past (tho not with CPF). Software was uninstalled, all physical files, services, drivers, and registry entries removed. Everything gone. But still there was a remnant of in some installer file somewhere, that kept messing things up. MSICUU can help with that. You got the VBS error when trying to run MSICUU; although something is obviously going wrong during the CPF install, it may or may not be related. Without an error message, it’s hard to tell from this end. Trend Micro and the others have helped you remove their software, but they may not be looking at/thinking about vestiges of files created by the installer (as they’re probably using 3rd party installers such as InstallShield, etc, rather than their own).

On the other hand Comodo does use their own installer; and should know every detail of the install process.


Thanks Little Mac and AOwL for your help.

Unfortunately, I never could get the install wizard to start, even after all of your help and suggestions.

In the meantime, Kaspersky has made changes to their 6.0 AV that allow it to work with Zone Alarm.

So… even though ZA is an inferior product IMHO, it works on my system, and I have real work to do, so for now, I surrender.

Best regards: Kevin


Sorry to hear that, but I understand your situation. Oddly enough, I just read from another user whereupon trying to install CFP on a system with Kaspersky running, Kaspersky told him that CFP could not be installed as they were not compatible.

I didn’t see in your earlier posts that you thought there was an issue between the two; perhaps I missed it. At any rate, CFP version 3 should be coming out soon, with a full-blown HIPS for virtually complete prevention of malware. Keep your eyes peeled…