Install & Uninstall Problems [Merged Threads]

I found the reason: WindowBlinds (:AGY) … after I uninstalled it I finally was able to install CPF3. Now it works like a charm … :BNC

Until today I used all alpha, beta and RC versions of CPF3 without any problems. But now I have >an issue. I tried to install the final version of CPF 3 (after a uninstalling RC1 which was managed by >CPF3). After a reboot whenever I try to install CPF3 almost immediately a Windows message pops >up saying that the Comodo intaller isn´t working any longer … and thats it … (:SAD)

I downloaded the installation file again … same result …

Any ideas? Temporarily I switched to Jetico … but I want to have my CPF back …

Ragle

Windows VISTA Ultimate x64
ESET NOD32 v3.0

I love comodo firewall however, it recently makes my life sooo hard. Especially the latest version. SO what happen was I installed it and its working properly then I noticed that there’s a lot of pending files in the defense plus system…so what I did was (my bad) put all those files in the quarantined area. Unknowingly that it contains the files of CFP itself. I mean it should recognize that it a trusted application ryt? Now, I cant even open the icon. It gives me an error message that it cannot find or locate the file. So what I did was tried to uninstall it (NEVER WORKS) I tried to follow the steps or rather the instruction on how to uninstall manually with no avail. I tried to repair it…to no avail…tried to do system restore to no avail…I’m begging someone to help me with this…

When I tried to install again…it doesn’t work its showing that there is a CFP already installed ask me if I want to uninstall it click yes…nothing happens. When I tried to delete the files it shows that a program is running and cannot be deleted…Thanks

am using XP sp2, Intel Core 2 Duo,…

ei, I was able to fix the problem… I read the solution in this forum as well. anyway thanks for everything…

Okay, so I had the beta (3.0.10.238) installed on Vista (Home Premium / 32Bit) and it was working mostly fine but I decided to upgade to th final version (3.0.10.268) and after I unstalled and reset, I ran into some problems.

Comodo has seemingly no files on my PC and is no longer listed in Add/Remove but when I try to install it (Either version) it says:

COMODO Firewall Pro is already installed on your system. Do you want to un-install it now?

And if I try to run the beta install it simply adds Beta to the name at the beginning. When I click Yes, nothing happens and if I click No, well, by default it stops the installation

This would be slightly bearable if my internet was still working – yes, for some reason, I cannot access the internet when I’m in this little void unless I boot into Safe Mode with Networking Enabled, at the moment I’m on my laptop.

Other info:

  • Logging on as an Admin account (But UAC is still present)
  • AVG is installed, latest version

So, I think I need to just completely purge all Comodo related files/registry entries, etc so I can install it. Actually, I first and foremost need the internet back – seriously. I can’t wait to get it all working, Comodo is excellent, best firewal I’ve used since the old days with BlackIce and others.

Vitals:

OS: Windos XP Pro SP2
Firewall version: COMODO Firewall Pro Pro 2.4.18.1 (prior to problem); ver. 3.0 when problem occured.

The Problem:

I just installed Comodo Firewall Pro version 3. I downloaded it from the website, and after comparing the MD5 checksum, I installed it.

I had Firewall Pro 2.4.18.1 installed and running, but I didn’t think I needed to shut it down.

Upon running the install, it informed me that I already had Comodo installed, and asked if I wished to uninstall it. I clicked “Yes”, and then waited while it uninstalled, then prompted me to reboot.

I rebooted.

The PC rebooted but the new COMODO didn’t autostart, so I attempted to launch it manually (clicking on the desktop shortcut). Instead of starting I got an error message:


cfp.exe - unable to locate component:

This application has failed to start because FLTLIB.DLL was not found. Re-installing this application may fix this problem.

I tried to reinstall; but I couldn’t because the uninstall prompted the same error message. No FLTLIB.DLL located, so now I cannot uninstall, reinstall or anything.

I’m basically stuck with an apparently “broken” COMODO firewall pro installation, and I don’t know how to proceed.

Kindly advise on what I should do so I can get the firewall up and running.

Thanks for your time and consideration.

Recd message to upgrade to v3 - which I did. It said it had to unistall v2 and asked me to reboot. All fine. When I restarted I had no Firewall I downloaded v3 tried to install and said it was already installed - gave me an option to uninstall - which I did but nothing happens. I now cannot uninstall or install v2 or v3. I have run CCleaner but still no success… How can I clean this up to use either v2 or v3. Is there a CFP removal tool that gets rid of all the entries? At present I dont know whether i have a firewall or not and very nervous about internet connection.

Surely someone here has a suggestion and I assume people needing to completely remove Comodo or force an install is not that uncommon.

:(:(:frowning:

Edit: Here’s an example of another person with more or less the same request: https://forums.comodo.com/help_for_v3/cpf_v3_cannot_install_or_uninstall_v2_or_v3_help_please-t15334.0.html

And I’ve seen numerous others asking similar questions to no avail.

It’s important to remove completely v.2 before installing v.3. Upgrading over the top
doesn’t work - different engines.
I had no trouble doing it this way (lifted from an older post):-

1. Go to Start/Run, type "msconfig", go to the Startup tab. Make sure if there's any entry for CPF checked, that you uncheck it, click Apply, OK. You don't have to reboot yet.
  1. Then, in CPF, go to Security/Advanced/Miscellaneous, and uncheck the box to Protect Own Registry Keys. OK. Go to the Summary page, and move the Security level to Allow All.

  2. Go to Start/Run, type “services.msc”; find the entry for Comodo Application Agent. Double-click, and set the start type to disabled. OK.

Now run the uninstaller on it, and reboot when finished.

Then run the registry cleaner and reboot.

Turn off/deactivate ALL other security software (Antivirus, Antispyware, HIPS, Windows Firewall, etc) then reinstall CPF.

Use the free Regseeker to remove all refs to comodo (backup registry first with Erunt or
at least ensure that backup is ticked in Regseeker.)

I love Comodo firewall, it’s great, it’s the best firewall that i’ve used.

On XP Comodo v3 installs perfectly, i’ve got no problems with it.

But on Vista, i start the installation process and everything goes according to plan. It works flawlessly then it comes to the email and activation, after this when I’ve clicked finish it pops up:
“Problem with deleting the Shortcuts. Please kindly delete the Shortcuts manually”

That is the whole message. From there it goes into the repair folder. I get no option to restart the computer and the installation fails.

I’m running:
OS - vista Business
RAM - 2Gig
Graphics - Nvidia 7600GT 256M
Processor - 2.93 Gig

Also i’ve tried installing as Administrator and still get the same problem, it stops at exactly the same point.

Previously I has PC Tools Firewall plus and the Vista Firewall working together, and everything was fine. Both of those were uninstalled before i installed Comodo. I’ve restarted my computer a number of times but to no avail.

Anyone know what’s going on ??? ??? ???

I’ve been waiting for Comodo to be vista compatable for months and it finally is but now i can’t use it :‘( :’(

I used Windows System Restore to revert back to a previous restore point. So now I’m rockin COMODO Firewall Pro 2.4.18.1.

I really would like to update it, so I’m wondering how I should proceed to accomplish this without running into “Dll hell” again.

Now that your PC is operative again. If you still have the v3 download then delete it in case of corruption then go to the Comodo site and download a new copy of V3 to your desktop and leave it there for the moment. Disconnect from the internet and uninstall Comodo 2.4 and then reboot your PC. After reboot and while still offline temporarily exit any other real time security systems you have eg Anti Virus, BoClean, Spybot Teatimer etc and then install Comodo CFP v3 to your PC. After installation you will be asked to reboot and then Comodo should be fully installed on your PC and your other Security should also be working as well.

Hi,

You could try RegSeeker or some other registry cleaner. Or you could look for “comodo” in the registry and delete the matching entries. Or maybe just reinstalling and uninstalling the beta in safe mode or at least with your antivirus disabled.

Thanks for the advice, bluesjunior . Did a second attempt as follows:

  1. Downloaded a fresh copy of v3 from the Comodo site.
  2. Deleted Comodo 2.4 and rebooted
  3. Disabled AVG Antivirus, Apache, and privoxy. I didn’t have any other security software enabled at the time.
  4. Installed Comodo
  5. Reboot as prompted.
  6. Still get the same error message (FLTLIB.DLL missing)
  7. Restored Windows.

I honestly don’t know what to make of it. I’ll give it a 3rd try (always a charm right?) tomorrow… this time disabling all services (such as Python and such) that aren’t MS related. I didn’t have this problem with Comodo 2.4 when I installed it, so I can’t imagine what I’m doing wrong.

hello out there
upgraded to v3 today,everything was okay for a little while then i noticed half of my programs were not working.kept getting error message stating,not a valid 32 bit application
could not uninstall firewall,went into safe mode and uninstalled it from there.downloaded version 2 but when i go to install i get message saying comod firewall is already installed on your system do you want to uninstall.click ok and nothing happens.checked in add/remove programs and cfp does not show same with another uninstaller.cleaned registry etc,trying desperately to reinstall to earlier version
any ideas anyone
thanks in advance

wolfie

I installed V.3 a few hours ago and I am attempting to uninstall it because it is wreaking havoc on my system, however it will not uninstall. It seems hung up at what looks to be about the 95% level. The box is titled Uninstalling and it reads inside as “Comodo Firewall Pro is now being uninstalled / Cleaning up…” I t has been stuck at that point for about the last half hour. Also CPU is running at 100%.

Any help would be appreciated.

Regards,

Hello FLGibsonJr

Welcome to Comodo Forum

It looks like a bad uninstall. Try installing again and then uninstalling in safe mode. This should help.

John

I installed CPF v3 on a new laptop yesterday without difficulty. However I found that the Desktop icon was inactive. In the C/ProgramFiles/Comodo/Firewall folder I also found inactive the cfp icon, the cfpconfig icon, and the crashrep icon, also inactive in the Repair folder.

After reading all the nightmare stories of uninstalling and reinstalling, I was more than a little intimidated to try uninstalling v3. But I sucked it up and uninstalled it from the Add or Remove Programs. Worked like a charm. No problems. Except the same result with inactive Desktop and Program File icons. The system tray icon IS active, and the Firewall is working - I don’t understand some of what is going on (like the Idle Process issue) but there are no glaring problems with functioning.

This morning, I turned on my PC where I have had CPF installed for quite a while, and I got a pop-up asking if I wanted to upgrade to v3. So I just did it, I followed the screens, I did not uninstall the previous version. Again, worked like a charm. I have a fully funcitoning product, but again these same inactive desktop and program file icons. System tray icon is fully active. It seems odd that this would happen on both the laptop and the PC in exactly the same way.

Any ideas?

Thanks,
Russ

Hi Russ

Glad to hear your install went well. The inactive icons on the desktop and program files seem to be by design. They will start the program when stopped but will not open the GUI.

John

I googled that FLTLIB.dll and there are fixes available for it online. I am no expert so don’t know what else to tell you.

Windows XP sp2 32-bit
Comodo 3.0.13.268

How can I reinstall it?