Install Signatures error

For the past 3 days, I have been getting an error when I try to update. On the desktop icon for Comodo is an orange bar that says ‘Needs Attention’ and when I click of the ‘fix-it’ button, it downloads the signatures, but I get an error message when it tries to install the signatures -

Task: Install Signatures,
Status: Class not registered

I downloaded and ran the Comodo Cleaning Essentials. Tried to update the signatures again, and still getting the same error message.

I am running Windows Vista 32-bit.

Any help will be appreciated!



Please run the diagnostics and see if they find any errors.

I have the same problem since Saturday - diagnostic reports no problem. Reinstalled Internet Security and problem remains… (attached)

[attachment deleted by admin]

Hi and welcome,
What Database version shows in about?
Title bar controls

Hi - see attached. I also manually downloaded the virus file (bases.cav) from the comodo website to install manually and i get the same error

[attachment deleted by admin]

Note: My following suggestion is a long shot and might not fix the issue, it will also cause the complete Database (Est 150MB) to be downloaded again.

This will only fix the issue if the cause is corruption in the Database file.
Navigate to the C:\Program Files\COMODO\COMODO Internet Security\scanners folder and rename the ‘bxxxxxxx.cav’ file to ‘bxxxxxxxold.cav’ then try to manually update the Database.

If successful the previous ‘old’ file can then be deleted.

Thanks for the quick replay - I tried the procedure mentioned and no change - still get the same error.

me too. no change.

Would deleting the Comodo Dragon be the cause of this? I deleted the Dragon because I never used it…

Hi MrsOcean,
No deleting it would not interfere with CIS or CCE, Dragon is a totally separate program that is also optional during installation.
Sorry a solution has not been found.

Try downloading the latest full av database as described in [url= can i download the latest full AV[/url] and see if that helps.

Keep a copy of that .cav file in case the above does not work. Next step is to try to import it from the Comodo About screen.

Database ver. shows 16458

Would it help to uninstall & reinstall Comodo Internet Security Pro 2013? I still have 221 days left on my subscription so I don’t want to throw all that away by installing a completely different internet security program.

Also, I have downloaded it on to 2 other computers in my home and they are running Comodo just fine. It only seems to be an issue with my computer. I was going to try to call live help tomorrow evening after work and see if they have any other suggestions.

I ran diagnostic this evening, again, and it found no errors. I saved the report.

If you don’t have complicated rules created the easiest solution is probably just to reinstall CIS. To do that please follow the advice I give in this topic. Be sure to also run the removal tools for any other security programs which used to be installed on this computer.

This will likely fix the updating error. Please let us know if that helps.

Reinstalling the software will definitely solve the problem.

  1. Uninstall from Control Panel (Add/Remove Programs)
  2. Use the unofficial Removal Tool for CIS 6 from here (options 4 and 5 in the removal tool aren’t necessary)
  3. Restart your PC
  4. Install CIS


Just an update: I did uninstall CIS and reinstalled it. Entered my keycode, and it has downloaded and upgraded the virus signatures 4 times in the last 24 hours. Everything seems to be running normal now.

Thank you all for your help. BTW, now the same issue is happening to my husbands computer so we will fix his the same way.

Thanks again.
Paula aka MrsOcean.

I did all of your instructions but no success.I believe its a problem with new version.
I switched to AVG AV Free with CFW. :frowning:
Hope to be solved soon…

I’m also having the same problem.

It’s got to be the program update that broke something for so many people to suddenly start having exactly the same issue.

The last successful update on my machine was just before a program update from build 2813 to 2847 as far as I can tell.

Is there any way to get Comodo to produce a verbose log? All we need to know is which class isn’t registered…

Diagnostics found no problems - Diagnostic results attached

[attachment deleted by admin]