Install problem

I want to install the Browser on my D drive . The install window says to use browse button to do this. There is no browse button that I can find andI cannot edit the default C location

What version of CD did you download?

What OS are you using?

It is the free vrssion & there is no indication of the version number but I just downloaded it from the Comodo site 30 minutes ago

I am want to load it on WIN XP media edition SP3 32


Do you have the link to the download still?

Here you go

Alright, so that is version then. (Latest stable). Thank you.

Well I decided to run it on the C drive. This must be a joke ---- right? It fired up after the install and all I can get is a blank page. It won’t even connect to the default Comodo site . I tried another download and install and the same thing happened.

So no pages load?

correct. nothing loads just a blank page & no indication on the router that anything is even connecting or trying to load :frowning:

Is your firewall blocking CD?

Nope!! first thing i looked for

Very strange, I have the same version of CD running on XP Pro SP3 32 (similar to Media Center) without this problem. If you use proxy software, try disabling it and rebooting. You could also try deleting the CD entries from your firewall and let it ask permissions again. Which security softwares do you use?


I had a similar problem with one of the earlier builds of CD. It turned out that it would only run (load pages) under the account that installed CD (which would have been administrator). Running CD under my limited account would not load any pages. Then by magic, it started working fine a few days later but i didn’t change anything ???. Btw, my setup was XP Pro SP3.


Thank you Sal, Jahn & Graham1 for trying to help me with this problem.

I solved the problem by shutting down all my security programs and then ran CD and it connected with the default Comodo homepage. I then fired up each security program one at a time and CD connected each time.
I now have all my security programs operating without any changes to the pre-CD installation configurations and CD fires up as expected. I don’t know why this should be but I am not about to question the results :slight_smile:

You’re welcome - thanks for letting us know. :-TU