Install Fireweall Update--Nothing will open!

I have been using Comodo Firewall on a Windows Vista laptop for several years. Today processed a update and, since then, nothing on the desktop opens. I occasionally can get something to open but freeze immediately with the message “Login process has failed”. Everything works fine in Safe Mode. Have tried Uninstalling Comodo in Safe Mode but you are not allowed to Uninstall in Safe Mode. Tried to Delete Comodo from Program Files and get message “You don’t have permission”. Tried uninstalling from Control Panel Programs and Features but it too says “You don’t have permission”.

Can anyone tell me what I have to do to Uninstall Comodo so I can get my computer back to normal? Thank you.

What version where you using before?

You need to have administrative privileges to uninstall.

I don’t know the version and when I try to open the app now, all I get is a blank page. I’ve tried a couple of System Restores to back before today may account for that.

I am the Administrator of this machine I’ve had for 5 years. How do I get Administrator privileges to Uninstall Comodo. Keep in mind I’m operating in Safe Mode with Networking. Thank you very much for your answer. I believe I can get back to normal if I can just Uninstall Comodo.

I’m not familiar with system restore so I can’t answer on that. I’d think it should get you back to where you were before any changes.

I believe that in safe mode you should be able to delete the Comodo folder outright. That’s pretty much nuking it in the roots. That should allow uninstall to proceed in protected mode, i.e., normal startup.

Do you remember if the original version had the tabs across the main UI? That would most likely be v5. Did you ever export your configuration from that? If not, it would seem your going to lose several years of accumulated rules learned.

A lot of ugrade problems are occuring with v5 → v7 upgrade. Its much better success to clean install v6.3, import pre-existing config, and then upgrade to v7. But even better to clean install v6.3, import v5.x config, get it all working, and then export config for now functioning v6.3. Then clean install v7 and import v6.3 config.

Major version upgrade is always a pain, e.g., Win95 to Win98 upgrade were fraught with prollems. Clean install of Win98 usually installed well. Same with Win98 to Win98SE upgrade, rather than clean Win98SE install. I fear the same is with Comodo v5 to v7; although for me the internal upgrade from v6.3 to v7 went w/out prollem.

You can use the Geekbuddy removal tool in Safe Mode. That should get you back on track.

Thank you very much, Eric! I’m hoping that will do the trick. Have just run it on the problem computer and currently restarting. I’ll let you know one way or the other.

Good news, Eric! It worked and I’m nearly back in business which will no longer include a Comodo firewall for sure! Everything is working okay except I lost my wireless but I can handle that and get it fixed tomorrow. Thank you very much for posting the exact solution I needed. I’m 86 years old and had been working on this for 6 hours and am really tired now.

That tool will do the job for the most part.

the following keys may not be removed if ‘access denied’ is displayed while the Geekbuddy tool is running (you can rerun the tool multiple times w/ out prollem. If there’s an issue you’ll see ‘access denied’ scrolling up in the output. Use Ctrl-S to pause / restart execution) :







Where XXX = numbers running 001 to something.

To remove those keys:

Navigate to above registry key starting with 001 for the numbers, check each subkey aforementioned, and iterate through to CurrentControlSet w/ out number suffix. If the registry keys are missing then press on.

Right click the key and select properties, permissions.
Tick the ‘full control’ box for ‘Everybody’
Click ‘apply’ and ‘o,k.’
click advanced
tick the ‘replace permissions entries on all child objects with entries shown here that apply to all child objects’ (this makes the ‘apply’ button visible)
un-tick the box just checked.
only the first box should be ticked (this has makes reference to ‘inheritance’ from the parent)
Click ‘apply’ and ‘o,k.’
right click the key and select ‘delete’

If the key doesn’t delete, you have to drill into it and do the same for the 0000 sub-folder. The parent folder should delete.

Many thanks, WxMan! I did notice a lot of access denied as the lines rapidly passed by during the running of the tool. The good news is I’m back in business 100% so it did enough for me. And now with your good help, I’ll be able to clean up the remains. I am forever grateful!

Those are prolly the last vestiges of Comodo. Dunno if those keys are horking install / updates / upgrades.

All I know is that I had heck of a time wtih the v5.12 to v7.0.x in-line upgrade. It resulted in just what you describe. Uninstall of v7 and clean reinstall of v7 caused unuseable stuttering system. Uninstall, run the cleaner tool, blew away the aforemetioned registry key prollem-children and install of v6.3 resulted in completely functional CIS (and after importing 4 year old grandfathered config painstakingly and lovingly maintained throughout all the releases since Feb 2010).

Auto in-line upgrade to v7 went w/ out hitch thereafter.

Works good last long time.

To remove the socalled Legacy Keys, which are otherwise hard to remove, open Device Manager from the command prompt using the following two commands:
set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Set Device Manager to show hidden devices under menu option View. Then see if there are Comodo Internet Security related drivers left in non Plug and Play drivers. If so select the driver → click right → uninstall. Do this for all present CIS drivers. Do a reboot when it has been requested.

Sometimes it happens that you can’t connect to the internet after uninstalling, using the clean up tool or trying a manual deinstallation. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

Note to all. I noticed on a vista machine that is used without user account control function enabled, that after CIS version 7 did it’s most recent program update, that the user account control function somehow became reinitiated. If this issue also happened to cbwilsha, this could be the cause of the inability to perform administrative functions. Just a thought.


One of the quirks of Vista :slight_smile:

Even though you are running in a Administrator account you do not have administrator functions for everything.

My many thanks to all of you who have taken the time to post with many helpful hints which I will pursue today to try to get rid of the remaining vestiges of the Firewall. This is my wife’s computer and she is just happy to be back in business 100% as far as her usage is concerned and she sends her appreciation also for all the help.

Go figure. Thanks for the info Dennis.