Incremental Backups

Is there a way to specify to CB ( how many incremental backups before it creates a new full backup?

Thank you,

Yes, you can use the |REVISION_NO_MAX??| macro in backup naming, if you save the backup as profile or schedule.
For example D:\Backup\my_backup|REVISION_NO_MAX05|.cbu will recreate the full backup after 5 runs.


Thanks, that’s great.

May I offer a suggestion? Please consider including this option (along with maybe additional options, like number of days instead of number of increments) in the GUI interface instead of the hidden / esoteric macro section.


Thank you for the feedback.


I followed your suggestion for resetting incremental backups by selecting the REVISION_NO_MAX macro with a value of 4 and saved the backup as a custom backup. (simple file & Directory backup selecting a single small directory with a destination a local drive)
The first time I run it, it creates a full backup with a file name of xxxxx…0
The second time it creates a FULL backup AGAIN with a file name of xxxxx…1
The 3rd, 4th, and 5th time it creates incremental backups with file names of …2, …3, …4
The 6th time it creates a full backup with a file name of …1 and erases file …2, …3, and …4

The …0 file remains on destination folder forever.

What am I doing wrong? If this is normal it will take me twice as long to get started (and on large backups this is really long) and it will need twice the space.

I tried the 4.1 Beta with the same results


When you save the backup as custom profile or schedule, the backup job is created separately with the settings you made when you pressed “Save profile” or “Save schedule”. Then, when you press Backup Now, it rans the with the settings from backup steps (which may have been changed compared to the moment when you pressed save profile/schedule). So, pressing “Backup Now” in backup step 3, it doesn’t run the saved backup job, but it runs as a new backup. All new backups that are not saved as schedule or profile have revision set to zero.

To make story short, you need to run the backup profile from backup profiles list only. This way the 0 file will not to be created.