Incremental backup backing up the same files everytime though they don't chanage

I have three different backups to three different sites. Two of the backups run fine but one backs up some of the same files every time it backs up. These are static files I never open and nothing on my computer touches them, yet they get backed up every time. The type of file seems to be irrelevant, some are Apple m4a music files, two are word doc files, one is an excel file, and some are html files. Again NONE are open by me at any time, they are simply sitting there.

I am running Vista Home Premium 64-bit fully patched. I am running Norton Internet Security 2008 and have it set to allow Comodo to anything it wants. I am running 10.4.337.

What are your settings on the backup that is giving you trouble. Can you let us know or post some screenshots of the settings.


I am having the same issue with the same version of Comodo Backup, but I am running it on XP Pro SP3. I have used this backup job for a while and it used to work fine, backing up only the files that changed, but now, the job to backup MyDocuments folder takes many hours because it backs up files that have not changed.

I did change the destination drive to one that is connected to my new wireless router’s USB port, effectively creating a network drive. After some testing, it appears that this is the problem - Comodo does not seem to be able to recognize that the destination files have not changed when using this drive. The following test lead me to this conclusion:

I created a test job in Comodo, backing up a single folder to my network drive, and observed that it backed up every file each time I launched the job. I copied that same job to a new one and changed the destination to a directly attached USB HD, and the job correctly backed up the files only the first time.

I did see another posting that said when using a Network Attached Storage device, you should use the UNC path instead of a mapped windows drive designation in the job, which I tried, but it did not help. I hope I am able to get this working and it is not a limitation of the Comodo backup product and network attached storage.

Hi mreiter

Welcome to the Comodo forums

This should work ok for you. Double check all of your setting to make sure you didn’t miss anything. Check box checked for active backup, Service backup type, Service state is running on main interface. You should not have to use UNC path, I use only the windows drive designation.

Are you using incremental backup or full backup? Are you using synchronization mode?

Let us know how you do with this. You may have to experiment a bit.


I have the exact same problem, I am running XP sp2 with avast antivirus

I have checked all my setting etc but no luck

Hope someone can help

Thanks in advance



Just as a test, disable your antivirus (particularly the realtime component) and re-run the backup job.

First thought off the top of my head is that it is backing up files based off “Last accessed” date, rather than “Last modified” date.

just a thought,
Ewen :slight_smile:

Yeah I did try that, I had the same thoughts although it did not make a difference… if it did i would not be a good solution either way :frowning:

any other ideas

Thanks again

I have tried everything you suggested along with the pm suggestions and no success

I use this on about 8 computers and this is the only one giving me trouble :frowning: there must be a solution but it is not looking very promising…



Being that this is the only one of 8 that is giving you trouble, is there anything at all different in the makup/setup of this computer as compared to the others? Security apps? OS? Running as admin? If you can think of anything let us know.


Same problems, and I am fresh to this program. I backup Simple copy, Incrimental to FTP server. Even with new backup job I sometime get errors with copying files. I tried to open problem files - and they open normally. Also files that changed don’t get uploaded to FTP in incremental for me, while files that did not changed or accessed do being copied every time job is statred. Runing as admin on win xp pro sp3, have Firewall, NOD32 antivirus. thats it.
What can I do to help to find the problem?

upd: I experimented a bit with xls file that didnt copy’ed even if a cell was modified inside of it. Now I added alot of information in that file and increasing it size by alot, and it was copyed. Now I experimented and added in one cell “test” text. And size of excel file didnt increase.

did a lot of tests from my last post, and I found that problem applyes mostly to Microsoft Office documents. Somehow after copying a file, it changes date modefied = last accessed, so that’s from where we get loops. Dont know how to fix it, I tried to change file attributes, archivation, indexing, but it still does that. And I cant figure why. :frowning:

found it. Comodo doesn’t support’s unicode (currently tested in cyrillic) in filenames and path’s.

Version 2 of the backup is currently in development and can work with cyrillic characters (mostly). It will be fully functional in the release version.

The beta version can be found at

Version 2 BETA is missing quite a few of the features of version 1, but they will be added back in as the development progresses. It also include disk and partition imaging.

Hope this helps,
Ewen :slight_smile: