incompatibility comodo and z170 asus motherboard

Hello I am writing this post to make you aware of a bad bug that is affecting latest versions of comodo firewall. I am using an asus z 170 a which like all the other motherboards of the serie has realtek audio drivers.The following iussue has been experienced with windows 7 64 bit and windows 10 64 bit.
After installing comodo cmd_fw_installer_6113_c7 I noticed that the sytem started getting frozen while I rebooted it. I Logged in in safe mode and startred enabling together with comodo firewall one program after another till I found out that the realtek drivers are incompatible with the last comodo firewall.

To solve this iussue I have been trying to downgrade the version of the drivers but nothing to do( I tried each of the available ones from the asus download page and even the ones coming withtheir cd).

In the end I installed an older version of comodo firewall cmd_fw_installer_6106_c6 which works just fine as long as I disable updates: infact if I allow it to update and make it go to the newest version the problem comes again.

Please may you fix this iussue ? I love comodo but this will make it unusable for owners of motherboards z170 from asus with realtek audio chipset ( used also in many motherboards of the rog serie).You will find audio drivers I tested and specs here:

If it’s possible try to check also the cfos asus turbolan utility, it’s a great utility for gamers it’s pity to uninstall it . Thanks

Please provide a diagnostics report. (main interface > question mark (?) > support > diagnostics)


Hello,qmarius.Thanks for Reply .I have sent you a pm with the attached link to doanload the file you’ve requested. At moment I removeed comodo and I am using privatel. I tested privatel and zone alarm and I can tell both are working good without freezing pc during reboot (which happens only with last version of comodo free firewall).


Hello qmarius, I sent you a pm with the requested file. I misunderstood you the first time. I hope this helps to understand what is freezing my pc when I reboot. Thanks for your help.

  1. Enable “Complete memory dump” : Support | Trend Micro Help Center
  2. Get attachment : Comodo Forum
  3. Run “rCtrl+2ScrLk_ON.reg”
  4. Restart system
  5. Try to replicate issue again
  6. When you experience a system hang, press following keys : right Ctrl + 2 times x Scr Lk
  7. Go to Windows folder & archive following file : MEMORY.DMP
  8. Provide a link by PM to mentioned archive

Thank you.

[attachment deleted by admin]

hello qmarius I have followed your instructions. I rebooted and there has been no bsod event, no bue screen, just the system frozen during rebooting. I clicked right ctrl key and 2x “block” key that on my microsoft wireless desktop elite keyboard should do the scroll lock you mentioned. When I came back in windows I went to the default pat for the file you requested but there was nothing.The location for the file you requested on my pc is the default %SystemRoot%\MEMORY.DMP and I didn’t find any memory.dmp file.

Have you tried disabling any/all of the components (AV/Firewall/HIPS/Sandbox/Webfilter/Viruscope) and rebooting? Do you have “play sound when an alert is shown” under gerneral > interface settings enabled? Have you tried using the newest drivers from realtek website? Also do you have any custom asus software installed thats active that might conflict? see and

I too use a realtek soundcard and use the latest realtek HD audio drivers from the realtek website and haven’t had issues before. Though your issue could be specific to that motherboard.

I tried disabling AV and uninstaling it. Still I had that problem. I tried the realtek from the cd coming with motherboard and the problem was still there. Then I tried each of threre version of realtek from asus site and still there.

Few ago I wanted to make a test I changed antivirus using ,instead of avast+ comodo, avira+ comodo , then I also went in services.msc and checked services there: windows firewall was not active but, BFE (base filtering engine) was active. It seems that Avast to work needs BFE. The nice new is when BFE is not active avira plus comodo firewall work just fine. I tried rebooting and shuting down the pc all was fine. This is strange I have been using Avast and Comodo together for years and never an iussue. Could it be that the thing that messes up the system is a conflict of comodo with BFE? After all when I ran my first test from safe mode not only the audio service was off but also bfe. Could be the new update of comodo has something that makes it create a conflict with BFE if it’s active?

From the Asus site the only extra software I added rather than needed drivers to make chipset and lan work is the AI suite to control my fan and oc profiles, but it seems just fine with or without it i have had no iussue.I use also asus GPU tweak II to change the state of fan and turn them always on when it’s hot, but there seems no problem with or without it installed.

I had an Asus p5q with comodo and avira installed for years and windows 7 64 bit and never an iussue. if it’s not the audio then must be a conflict of BFE with the comodo newest version/update.

Does Comodo need BFE to work fine? I had no request from it to use BFE active. I also read from windows forum that using a third part firewall it’s better to have windows firewall process and BFE disabled.

About viruscope yes I keep it disabled and also the sandbox I don’t use them often. So even using them turned off the problem persisted.

I disabled the traffic filters and it went good for 1 time then at next reboot the problem was back.

:o It’s again there and it disappears only if comodo is not installed or the audio realtek are turned off from msconfig

Make sure that you have enough space, pagefile and you hold right Ctrl button in the keys combination.

I think that your previous hint worked, but I had to use a workaround. I removed Ai suite and audio using the program tweaknowregcleaner and I cleaned all the tracks. Then I installed older version of ai suite and audio from cd of the motherboard. It seems that newest versions of the software could have that iussue. Now I am back again with Comodo, happy with it after years of using it andI can say it’s running smooth. I can reboot and shutdown. Thanks for the help.