inbound/outbound does not show virtual machine connections

The Comodo installed on my host computer can always show the inbound/outbound connection of the virtual system running in VMware. But I just noticed recently that it does not show anymore. Can anyone help? Thanks.

You need to make sure the Comodo Firewall driver is both listed and enabled with a check box in the network adapter properties. If if is not listed then the driver is not compatible with the adapter.

Thanks for your reply.
Do you mean it needs to be in the VMware network adapter properties as well? It has been working all the time until recently, so is there a way to add it back to the list? I recently updated the firewall I’m not sure if it’s related.

Yes it needs to be listed and enabled for whichever adapter VMWare is using for the VM depending on how you set up networking for that VM. It would be much easier to re-install CIS as it will add the firewall driver for each compatible adapter. But if you wish to manually do it then you need to click install within the network adapter properties and then select service and look for comodo internet security firewall driver.

I tried re-install and it’s still not working. I tried to add it manually to the list but it doesn’t show when I click install. Does it mean somehow it’s not supported suddenly?

No something is wrong as it wouldn’t be supported all of a sudden, what version of VMWare are you using and which OS? Also which adapter are you checking from VMware?

I’m using VMWare workstation pro 15.1 and Windows 7 (both host and vm). I checked the local area connection adapter (which has comodo driver) and VMware network adapter (which doesn’t have the comodo driver) as shown in the pictures.

Looks like VMWare changed the adapter type which isn’t compatible with the firewall driver, so you were updated to a newer VMWare workstation, I do know that the firewall driver is enabled in the virtual adapters in v12 of VMWare workstation.

Ah… thanks