In Windows 8.1 unrecognized apps not run restricted from network drive [M1234]

1. The full product and its version:
COMODO Internet Security 8.0.332922.4281 BETA
2. Your Operating System (32 or 64 bit) and ServicePack revision. and if using a virtual machine, which one:
virtual machine : virtualbox 4.3.6 r91406
windows 8.1 up 1 x32

3. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?:
Default configuration

4. Did you install over a previous version without uninstalling first, or import a previous configuration file?:
Clean install

5. Other Security, Sandboxing or Utility Software Installed:

6. Step by step description to reproduce the issue. Or if you cannot reproduce it, what you actually did before it happened, step by step:
1: On a Windows 8.1 computer, move an unrecognized application, which is run under restriction if run from C-drive, to a network folder.
2: Note that if run from the network folder it will be run without restriction.
3: Note that on a Windows 7 (Also run in Virtualbox) computer the same application will be run with restriction if launched from a network folder.

7. What actually happened when you carried out these steps:
On the Windows 8.1 system, if the app is run from the network folder it will be run unrestricted. On the Windows 7 system, if the app is run from the network folder it will be restricted.

8. What you expected to see or happen when you carried out these steps, and why (if not obvious):
Any unrecognized application run from the network folder should be restricted, especially if it will be restricted if run from the C-drive.

9. Any other information:
A video showing this behavior is attached to this post.

[attachment deleted by admin]

Thank you for reporting this. I have a few questions.

First, how did the application get on the computer in the first place for both of these tests? CIS keeps track of this, thus it’s important to note it in your bug report. Also, make sure there was no difference in the way in which the application was moved around (meaning copied from location to location) for comparing the two tests. It’s possible that an app copied to the network drive and back to C-drive, and then tested may behave differently from an app tested on the C-drive, and then tested on the network drive. Thus, please let me know those details of the test.

Also, you state that you tested Windows 8.1 in VirtualBox. Did you test Windows 7 in VirtualBox as well?


I ran the application directly from the network file on Windows 8.1, but it is not run under the the restriction, applied to that I tested a file transfer application from the network to download file.
As you know, the transfer of any application is not defined, whatever the source file to download will actuation within the the restriction
I tested on Windows 7, and conditions were completely identical .In each of the two tests were run the application in the network file.

Thank you. Was Windows 7 also run in VirtualBox?

yes, :azn:

Okay, please attach a diagnostics report and I will forward this.


The report is attached

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

in windows 8.1 x64, When running an unknown application from unknown network file be restricted application

Maybe there is a problem in my Windows

Thank you. I have passed the information about Windows 8.1 x64 working correctly into the tracker. If you find that there is a problem with your copy of Windows 8.1 x32 please let me know and I will close this. However, until then I will keep this open.


The devs have tried to replicate this, but they have not been able to. I’m thinking that this may be related to something particular about your environment.

Please attach pics of any network settings which may be relevant to your next post. Also, the devs have requested a video showing this issue. Would it be possible for you to create one and also include in your next post?


I’m re-testing on Windows 8.1, but this time on a new system and there are no any problem

The problem in the report still exists

[attachment deleted by admin]


I’m re-testing on Windows 8.1, but this time on a new system and there are no any problem in my windows 8.1

The problem in the report still exists

Thank you for testing this, and I am happy to see that it appears the problem is not re-appearing. However, please specify what problem there was in the report. I’m sorry, but I’m not remembering any other issue related to this.


The problem is still exist on Windows 8.1

Please specify what the problem is which still exists on Windows 8.1.


this :Comodo Forum

Thank you. I have finished watching the video, and will attach it to the first post. Am I correctly understandign that you are still seeing this problem on Windows 8.1 x32 run from VirtualBox?


Yes, the problem still exists only in Windows 8.1 x32

Thank you. I have updated the information in the tracker.