Impossible to unblock port 113 identd (V4.0135239.742 X32)

First of all, this problem happens ONLY with Comodo Firewall v4+

The problem is that Comodo Firewall blocks port 113 so for me it’s impossible to connect an IRC server using identd authentification.

If you want to reproduce this bug, use any irc client with identd enabled and add to “Trusted App” in Network Security Policy of Comodo Firewall.
Now connect to an irc server of Undernet, for example: /server newyork.ny.us.undernet.org

you will see something like this:

[i]* Connecting to newyork.ny.us.undernet.org (6667)

Local host: DarkBlood (10.0.0.3)

-newyork.ny.us.undernet.org- *** Looking up your hostname

-newyork.ny.us.undernet.org- *** Checking Ident

-newyork.ny.us.undernet.org- *** No ident response

-newyork.ny.us.undernet.org- *** Couldn’t look up your hostname

-newyork.ny.us.undernet.org- *** Ident broken or disabled, to continue to connect you must type /QUOTE PASS 13558[/i]


After the second try I set Comodo Firewall to “Disabled” and I could connect normally using identd.

Does this program need port 113 for incoming traffic?

Did you try to add a global rule to allow inbound TCP/UDP to port 113 before the one named “Block IP In from IP Any To IP Any Where Protocol is Any”?

Adding any irc client as trusted app won’t affect global rules like “Block IP In from IP Any To IP Any Where Protocol is Any” which is a new default for CIS V4

[attachment deleted by admin]

thank you, it works Endymion!! (CNY)

so now I want to make a detailed guide to share my experiences :slight_smile:

“How to connect to an irc server with IdentD (port 113) enabled and still remain that port in stealth with Comodo Internet Security version 4”

If you are using an irc client (like mIRC) and want to connect to an irc server with IdentD enabled it’s not enough just adding to trusted app the irc client (mIRc.exe for example) or allow all the “Comodo Firewall pop-ups”, now with Comodo Internet Security v4 you need to manually add a new global rule and here the guide starts :wink:

Open Comodo > Go to Firewall tab > Click on “Network Security Police”.

http://img715.imageshack.us/img715/6122/comodo1.png

Go to “Global Rules” tab > Click on “Add…”.

http://img121.imageshack.us/img121/9872/comodo4.png

Now set “Action: Allow”, “Protocol: TCP” and “Direction: In” > Go to “Destination Port” tab and leave all other tabs by default > Set “A Single Port” and “Port: 113” > Click “Apply”.

http://img171.imageshack.us/img171/9221/comodo2.png

With the rule already added, select it and move the position up or down, until it snaps BEFORE the rule “Block IP In from IP Any To IP Any Where Protocol is Any”.

http://img689.imageshack.us/img689/9198/comodo3.png


Now if you want to test it out, run your preferred irc client and connect to any irc server that needs “Identd authentification” (like Undernet).

[i]/server newyork.ny.us.undernet.org

Local host: DarkBlood (10.0.0.3)

-newyork.ny.us.undernet.org- *** Looking up your hostname

-newyork.ny.us.undernet.org- *** Checking Ident

-newyork.ny.us.undernet.org- *** Couldn’t look up your hostname

-newyork.ny.us.undernet.org- *** Got ident response

Welcome to the UnderNet IRC Network, DarkBlood[/i]

What is the difference with IdentD enabled or disabled? you can connect instantly and automatic! because some irc servers have an “IdentD protection/TIMEOUT” and because of that you have to wait 30secs~ to connect or others have an “IdentD protection/ANTI-BOT” that makes you manually type some random characters before you can connect.

You’re welcome. :slight_smile:

It was very considerate of you to contribute a tutorial to the benefit of everybody. :-TU