Impossible to stop blocking program in sandbox mode?

Hello, I am using Comodo Internet Security 8 with latest updates to date and I have a problem with sandbox mode. I am trying to run a program called GlovePIE though sandbox mode which is a macro program and I have done so on my other PC but now on another PC it doesn’t work correctly though sandbox mode. I tried to run the program without sandbox mode and it worked fine, but I want it to be in sandbox mode to allow use of it in few games that block almost everything while they are open.
Defence+ Events screenshot:

I am not 100% sure if it’s related to Comodo itself but I think this is good palace to start as my friends are also having same issue while running some programs though sandbox.

I am trying to run a program that always get put in “Blocked Intrusions” for direct keyboard access and direct monitor access so I tried to change rules so it would allow it. It changed nothing so I tried to disable EVERYTHING and remove ALL rules and it still blocks it when I open it in sandbox mode… My CIS just hates me I guess…

Anybody has ANY idea? I tried everything at this point…

The sandbox automatically prevents some forms of direct keyboard and direct screen/monitor access and can not be configured to allow such access, you’re probably creating HIPS rules for the application but those rules are independent of the sandbox and therefore won’t affect the sandbox. If the application is working even with these blocked events then you can still use it as normal, but if it needs those type of access and doesn’t work in the sandbox then you need to run it outside the sandbox and control access using your HIPS rules.

So from what I understand I can’t make it stop blocking it in sandbox mode… This is weird because this program works in sandbox mode on some PC’s and not on others. I wish they bought back option to disable the blocking entirely. (From version 6)

Correct you can’t specifically control what the sandbox blocks when the application is being sandboxed. But you can control the level of restrictions for access rights using run restricted option see here for mode info(scroll down until Set Restriction Level). Is it possible that you may have added these additional level of restrictions on the PC that the application is not working correctly under when it is being sandboxed?

No I didn’t mess with setting on either of the PC’s until it didn’t work on some for no reason I can think of. Also thank you for help, I will look into the restriction levels maybe I figure out how to stop blocking certain features I need from this program while in sandbox.