Immense CPU usage after not updating for a week

I love CIS, but I have a little hangup. I only use my computer during the weekend, so i only update my virus definiton’s on the weekend, but while it is downloading all those virus definitions from 4 or 5 days ago, my cpu spikes to 50% and up just while downloading the updates. Please try and releae a fix, or i will have to move on to something else.
Also, could you create an offline updater please?

Thanks!!! :slight_smile: :wink: O0

Hi Compgeek,

I’m not sure if they will call it a bug, but it sure is a nasty side effect, i had the same with my test notebook and it took over an hour to update, while it renders the system “workless”.

The current merging process for the AV database is inefficient in these scenarios… I hope they improve this for the coming release.

Does excluding the pagefile from the AV on access scan bring any solace here? This trick helps older system with 512 or less MB of RAM.

I think the amount of memory is the key here. When I access my XP installation with 1 GB of RAM, after sometimes 5 or more days, it takes a while to process but it does not bring the system to its knees. It surely influences but I can start programs and even install applications.

I started experiencing this issue with the release of 3.12. I never used to have any problems before. I don’t need to wait a week though. Just having the system off overnight is long enough. Then a few minutes after startup when CIS starts its update, I can’t use my system for 5 or so minutes.

My system has 2GB of RAM, so I don’t think it’s a memory issue. I have excluded the pagefile with no success.

My hope is that Comodo sees this behavior as a priority issue. It’s annoying enough that I’m actually considering another security solution.


I use Ubuntu daily and Sunday start in Xp to update the CIS antivirus and the laptop becomes unusable for 10 or more minutes. I think it is a poor design the way signatures are updated. The suite works fine, but update the antivirus hangs, and the difference becomes quite noticeable when comparing the start in Ubuntu 9.10 and XP.
The solution: uncheck update antivirus before scaning in real time and update the antivirus manually when the PC is not in use. My solution for now is to use another antivirus, avast, until the developers solve the problem. :wink: