IMAP and the Firewall...

I am hoping someone can help me.

I use Outlook 2007, Windows 7 and Comodo. My Outlook has 6 or 7 e-mail accounts and my work IMAP account won’t send. It receives, but it won’t send (ISP is Verizon).

Others I work with have the same configuration (McAfee, not Comodo). They can get e-mail both ways. This wasn’t an issue until mid-October.

I tried to add a profile to the Firewall client to Allow Outgoing IMAP requests and set the appropriate port - but it does not seem to help.

I would appreciate any help or support anyone can provide.

Thanks.

TK Vanacoro

IMAP generally only needs outbound access to ports 143 and 995.

Are these the ports your IMAP mail provider uses?

Are there any relevant entries in the firewall / Defense+ logs?

I found nothing in the Defense logs. I can’t find the Firewall logs.

And, my employer, for some odd reason, uses Port 25 for outbound IMAP to their mail server.

Thanks.

The firewall logs are found at FIREWALL → COMMON TASKS → VIEW FIREWALL EVENTS

In this case IMAP isn’t relevant, Looks like port TCP 25 is blocked or the email client config is not correct, OR Verizon uses a secure SMTP option on an other port…

Does it work if you put the firewall temporarily to disabled? If so it’s a Firewall Policy issue.

How is your email client setup in the Firewall policy (FW, Advanced, Network Security Policy)?

I guess still being new to COMODO, I’m not sure how to just turn off the firewall without shutting down the application.

Does it matter that under Predefined Firewall Policies, block applications has an entry that say BLOCK ALL INBOUND AND OUTBOUND REQUESTS?

Thanks again.

Hi vanacoro,

Well you can disable the firewall while leaving the CIS GUI active, just right click on the tray icon and select “Firewall Security Level” note it’s current state and set it to disabled.

And for predefinded policies, it’s just a template, these can be used on the actual policy so on it’s own it does nothing, unless you assign this “template” to an application on the Network Security Policy, then that application can’t communicate in our out.

Well, the problem exists when the firewall is down, so it can’t be COMODO, but my fool SA who says it’s not her problem.

Thanks for helping me prove it’s not COMODO.

Hi vanacoro,

Depending on the problem you have it could still be “Attack detection” causing some issue’s…
What’s not working as it should?

Only that I can’t send e-mail via my work server (using Outlook 2007) and IMAP. The IMAP works on my G-Mail account and my work e-mail still won’t work, even if the firewall is set to off.

My sense is that the problem is at the e-mail server end.

Is that an Exchange server your are connecting to, and if so are you allowed to use IMAP?
AFAIK Exchange normally uses “exchange mode” with RPC connections, and admin has to allow IMAP for your account. And yes then this test should be sufficient with setting the FW to disabled.

Yes about Exchange and yes about IMAP.

She says IMAP is allowed (and other say it works), just not with my configuration (COMODO). IMAP to this exchange server is used by 50 people and it works fine. We thought since I was the only one not able to send and the only one using COMODO, that their might be a connection.

Thanks.

Probably the authentication causes issues, you can test connectivity to the server for sending traffic like this.

Open a command-box and type

telnet <name/or ip address of mailserver> 25

e.q. telnet mail.company.com 25

Press enter after it, if you get some connection banner or a blinking cursor on the top left you have connection to the server.

Can you also post the error message the mailclient gives?

Sending error report (0x8004219). “Outlook cannot connect to you (SMTP) IMAP e-mail client. If this continues…System Administrator.”

telnet webmail.verizon.net 25 returns a telnet cannot be found error…

I’m a bit confused. Should the telnet link-up be to my service provider (verizon) or the IP address of my work e-mail server…?

Open a command-box and type

telnet <name/or ip address of mailserver> 25
e.q. telnet mail.company.com 25
Press enter after it, if you get some connection banner or a blinking cursor on the top left you have connection to the server.

Depending on where you are and from which email address you wish to send.
I assume you wish to send with your work email address so it has to be your work mail name/ip

But this error message indicates that telnet.exe client is not installed on your system, for some reason M$ decided to drop that by default on Vista and Win7 installs. You can add it to your system if you like or we have to find an other way to figure out what’s going wrong…

Does Outlook have the ability to press “More” or “Details” etc on the error message?

And how’s your Outlook Outgoing mailserver setup?

** adding telnet;
Open Control Panel\Programs\Programs and Features, Turn Windows features on or off
Put a check mark on Telnet Client and follow the flow…

JUST FOUND THIS…

 Your Attention Needed: Re-configure Your Email Settings to Send Email

Most common email viruses are sent using port 25 to infect computers. Often times the user never knows their computer has been infected. In order to protect our customers, Verizon has turned off the ability to send email using port 25 for all users other than those using a @verizon.net email address.

If you want immediate step-by-step instructions, visit change my port settings to 587 now.

What is outbound port 25 blocking?

Outbound port 25 blocking is a network configuration change that will prevent computers on the Verizon network from connecting to servers outside of our network. Servers outside the Verizon network use a method commonly employed to send unauthenticated, unsolicited e-mail or “spam”.

Why is Verizon blocking outbound port 25?

The majority of spam (unsolicited email) on the Internet is caused by malicious software viruses that take control of infected computers. These viruses direct the infected machines to send email through port 25. Verizon takes spam very seriously. Verizon blocks outgoing connections on port 25 to prevent infected computers from being used by spammers to send unsolicited email. Outbound port 25 blocking is a standard industry method to control spam.

When will outbound port 25 blocking be implemented?

We will begin implementing outbound port 25 blocking in the first quarter of 2009.

Will outbound port 25 blocking apply to all Verizon broadband customers?

Outbound port 25 blocking will be applied to FIOS and High Speed Internet services that use dynamic IP addresses. If you subscribe to a static IP address service, you will not be affected.

Then they probably also setup a “mail relay” server where you can send out your email with what ever “from” address you use…

Do you access your work mailbox plain over the internet both SMTP 25 and IMAP 143 are not encrypted by default… i thought you where having trouble on your “work” network (being in the office…).