Images/Sites not loading with ComodoDragon-- it used to work, now what!

Don’t know if anyone can help but…

Some sites that I go to (i.e Google homepage) aren’t loading properly with the Comodo Dragon Browser. The images will be missing or the layout isn’t right. Not sure what’s going on cuz I know CD usually works fine. I just installed Internet Security Premium-- that’s when I noticed the issue. I uninstalled then reinstalled CD-- still nothing.

Hope someone can help because normally CD is so efficent…

Are you using Comodo DNS?

If so, try your Default DNS or try Norton DNS or try ClearCloud DNS, and see if you still have the problem. :slight_smile:

Yeah, I think I’m using Comodo DNS at the moment. How do you deactivate? I’m also using Comodo Internet Security so… not sure how that will come into play…

It is pretty easy (but on the last step, set it to Automatically Obtain The DNS Address :wink: :

Or you can use the Norton DNS Client or the ClearCloud DNS Utility which will allow you to use their DNS service and/or switch back to your Default DNS whenever you want. :slight_smile:

Maybe CIS (Comodo Internet Security) is the problem, I do not know, but I would check the DNS first; then we can check a few other things and try to troubleshoot/find the problem. :wink:

I’ve changed the settings to ‘automatic’ as you’ve suggested but still nothing. Any other ideas… really kinda annoying… grrr

Do you have an example (link) of a site where the images won’t load?

Yup… here you go. These are from the Google Search and MSN weather websites…

[attachment deleted by admin]

Check ‘Option\Under the Hood\Content Settings\Images’ and see if images are disabled.

Already tried-- setting is ‘run automatically’

Do these sites display correctly in other browsers?

Yep, no problems encountered so far by Firefox

Assuming you’ve no extensions that may be interfering and images and javascript ar on, there aren’t that many options left. I imagine you’ve purged the cache (check with about:cache)

You could download the portable version of CD as a test New portable Comodo dragon v 8.0.0.4

Well, the DNS does not seem the problem, so I guess you can switch back to which ever DNS you want to use.

  1. What Extensions are you using?

Type: chrome://extensions/ , in the Comodo Dragon Search Bar/Omnibox to get a list of your current Extensions. :wink:

  1. What Plugins are you using?

Type: about:plugins , in the Comodo Dragon Search Bar/Omnibox to get a list of your current plugins. :wink:

  1. Do you have this problem when browsing in Incognito Mode?

Press: Ctrl+Shift+N , to open up a Incognito Mode Window.

  1. Have you tried Un-installing Comodo Dragon and installing the Newest Version again?

  2. Do you have this problem in Google Chrome?

  3. Do you have the latest version of the Adobe Flash Player, Microsoft Silverlight, and Java?

http://get.adobe.com/flashplayer/

http://www.silverlight.net/getstarted/

http://www.java.com/en/

  1. Have you tried clearing your Flash Cookies in the several Categories listed in the Adobe Global Flash Settings Manger?

http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html

  1. Are you using another Hosts File other than the Default Windows Hosts File?

If none of that works, then we can try a few more things. :wink:

had the same issue since i installed dragon few days ago. this is the only link that pops in google about this issue and i can see that no one has the answer, switching back to chrome after this…

Hi Woomera,
Is the following enabled?
Options>Under the Hood Do not allow websites to know where you came from (suppress HTTP referrer header) option.
If yes please try it disabled.

Hi woomera,

Some time ago, I had a similar problem not with Dragon but IE. The images of sites could not be loaded in Internet Explorer anymore. I restored a previous image of my system and the problem was solved. Hence I suspect that my user profile got somehow corrupted.

Maybe your profile wasn’t correctly made during Dragon’s installation.

If I were you I would uninstall Dragon and run this uninstaller tool https://forums.comodo.com/install-setup-configuration-help-cis/uninstaller-tool-for-comodo-products-t71897.0.html;msg511531#msg511531 (choosing of course Dragon) to be sure there are no left over Of Dragon’s actual install. And then make a clean install of Dragon.

your user data is has an issue

follow the instructions below
backup your user data and and for CD to make a new one
then close CD and copy over almost everything from the old one …

this fixed my issue.