Image Verification Failed. Installer will now exit.

Can someone please help me. Im trying to install COMODO Internet Security on my laptop. Its running on Windows 7 Home Premium 64 bit.

When I try to install it, an error comes up saying Image signature verification failed.

If i go into the properties of the installer it says that the Digital Signature is NOT valid. Yet I downloaded the installer straight from the COMODO website and did in fact download the 64 bit installer.

I recently restored my laptop to factory settings so COMODO has yet to be installed.

How do i fix the digital signature not being valid? Im pretty sure that is the problem with why it wont install.


Welcome to the forum.

Are you trying to install from some other drive or device, that can cause the error.

Copy the installer to the desktop and run as admin, should go smooth.
Unless of course you have some other issue.


Nope, that did nothing. Ive tried everything i have seen suggested on these forums. None of the “solutions” worked.

As I said before, the digital signature wont verify for whatever reason. Thats what i think is causing these issues.

Ive managed to secure my laptop for now, But i really want this problem solved as soon as i can, COMODO is my favorite free security software.

Lets make sure we have the same, undamaged file.
Mine downloaded moments ago, is 57.5 MB and the signature does verify.





Where exactly do i find that info?

Here is a free utility to check File Hashes.

And have you done all your windows updates so you have latest root certs installed?


Windows Update is Updating stuff now, I didnt update earlier because some unknown error was stopping the updater from doing what it needed to do.



I think he has a corrupt DL.
maybe re downloading will result in a successful install?

Yes, our Hashes don’t match, so the OP’s appears to be damaged, corrupted somehow.

Unless… are you downloading the installer that is for both Firewall and AV?
and not the universal web installer option.

[attachment deleted by admin]

Thing is I have re downloaded multiple times with both IE and Firefox, same error every time.

More hashes from a file just downloaded



And yes, Im using the option for both the AV and FW, not the universal.

Got this error when running universal installer

4520258D9ACBD59C95F9F463D3FAFCA9D4BFF36D SHA1

EF05EC75860B848684C7EC5ADEAD3832 MD5

Could someone else verify these hashes above.


You went back to factory settings,
so do you have some other maybe trial security software that may be wreaking havoc?

I currently have trend micro installed and running that way my computer isnt open to attack while this problem persists.

That is baffling, the file is 57.5 MB in windows?
Could you try the hash checker a couple of times in case there was an error of some sort?

I can’t advise how to proceed if we can’t verify you are getting the complete and undamaged file.


Perhaps a dumb question, but you are sure you have Win 7 x64 and not 32 bit running on 64 bit hardware?
Doesn’t help with the hash, but another possible further snag.

Im 100% possitive unless im going blind or something

Ill provide hashes from a couple of the installers i have downloaded.



Installer # 2



They are changing with every installer i download.

Let’s only work with the one installer from the link above.

You could get rid of the others to help avoid any confusion.

And yes, the OS looks good.

Put all the installers I had in the recycling bin and emptied the bin.
Downloaded the installer from your link
Moved it from my downloads onto my desktop.
Here are the hashs



Digital Signature still not valid.

If you run the hash checker and close it a few times do you keep getting the same hashes?

There is no where to proceed if your hashes won’t match mine.
Need to find out what is corrupting your download.

Yep, pulls up the same hashes every time. Only time it changes is when i download a new installer. Other than that nothing. Still have a strong feeling that the digital signature is the issue here.

The sig is good though, it checks out.

If the hash doesn’t check out then nothing else will be right.

You’ve finished windows updates?