I'm at my wits end! IE / Firefox won't work & Avast won't update - Please help


I have installed Comodo on my laptop, but don’t know how to configure IE / Firefox / Avast.

I have followed the repeated advice on many threads, which states to allow these as ‘trusted applications’ & also changed protocols to ‘TCP or UDP’ & directions to ‘In / Out’

After many hours of trying to sort this out (including going away for a cuppa to calm down) I still can’t get IE / Firefox to work nor update Avast.

Please please can you help?

(p.s. - Is it something to do with proxies?)

I’m not savvy with the terms, so please explain in ‘dummy’ terms! :SMLR

Welcome. :slight_smile:

Are you using a proxy? I’m guessing not.

Anyway, go to Firewall > Advanced > Network Security Policy
Make sure firefox.exe and iexplore.exe are set as “Web Browsers”.

(To do this, select the application, edit, use predefined security policy, and use “web browser”.
Remember to Apply

In Defense+ > Advanced > Computer Security Policy set firefox.exe and iexplore.exe to “Trusted Application”.

With Avast, make sure in your network security policy that avast.setup is set to “outgoing only” and is set to an “installer or updater” in defesne+. Other avast entries in Defense+ should be set to “trusted app” as well.

Hello FaZio93

Thanks for your reply.

I have done what you suggested, but IE still says it ‘cannot display the webpage’ and Firefox just hangs. No luck with updating Avast either (:SAD)

I just don’t know what to do, other then remove Comodo.

That sounds more like an IE settings issue. Is is the yellow toolbar at the top reporting this?

If problems are continuing with avast and FF, remove all settings related to these applications in D+ and then set D+ to “Training Mode”. Use FF for a little and try updating (program and database updates) with avast. Then set D+ back to its previous mode.

May be the settings for System (where svhost resides as well?) is not right. Go to Firewall → Advanced → Security Policy → Application rules → let us know how the settings for System are.

Also take a look under Firewall → Advanced → Security Policy → Global rules. Can you post a screen shot of them?


After I don’t know how many hours spent configuring this that and the other, you won’t believe what was wrong…

My router needed a reset (:AGY)

Everything works sweet as a nut now, and it was just a fluke that I decided to try the router. :BNC

Thanks for your replies folks, and have a very Merry Christmas x

Congrats with solving it your self. Merry Christmas too.

I will close this one.