Ignore once bug

When malware is detected I click ignore once button, but message pop ups again and you have to click ignore once one more time.

  1. CPU Athlon 64 X2 4600+
  2. Windows XP pro, service pack 3, 32 bit
  3. CIS 3.8.64263.468
  4. Antivirus - default settings
  5. Firewall - custom policy mode
  6. Defense+ - clean PC mode
  7. Administrator account

Wheal, for me things just got worse.

Now I have to click a dozen times to make alert disappear.
While I was writing a post antivirus alert closed after 2 minutes, and file was left in his original folder. When clicking on the file I couldnt get access nor did I get a new warning. (Maybe it is supposed to do that, I dont know)
Now I did a right click scanning and clicked on results, choose ignore permanently button, and file was put on the exclusion list. I tried to open file but I get warning — Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item.— Also could not move or copy the file.
I did a right click scanning again, and comodo alert showed no threats detected.
In this folder I had two files and both where quarantined after full computer scanning. First one which I talk about in text above I successfully restored from quarantine, but for second I get alert --restore failed. The system cannot find the path specified—
Folder is in the same place as it was and I have access.
PS: Restore of second file failed even before I started messing with the thirst one. (maybe a new topic for restore)

I tried now to open file that I couldnt access and it is OK now. It opens and there is no warning because it is in excluded list. I didnt reboot or anything, just tried much later.

PS: Managed to restore the other file from quarantine, but I will explain it in proper topic.