IGMP alerts after upgrading to 5.12

I updated to version 5.12 of Comodo Firewall this morning and after the upgrade I get these IGMP alerts. Nothing changed on my PC except the update to Comodo. Didn’t change anything in settings either.

My settings:
Firewall mode: Custom Policy
Alert Settings: All options checked
Alert Frequency Level: Low

Does anyone know why this happens? Is there something bad going on on my pc or is this just normal behaviour?

I lost my rules for ping.exe so maybe you have lost something during upgrade also that causes this?
Do you have a backup of your config before upgrade?

Don’t think so.

Same here. Upgraded as told by Comodo Firewall 5.12 and today I am getting IGMP alerts with a games app I have never got any alerts in the last year.

I note one of the IP addresses is the same as the OPs screen-shot, namely 224.0.0.252

[attachment deleted by admin]

Also, same here - i’m getting IGMP request from various applications for connection to same multicast address.

I’m on Vista x64 PL with latest updates and ive updated from 5.10.228257.2253, then cleaned old inactive rules.

By the way, as far as i memeber between 5.10 and recent build were some Comodo updates - i didnt get any. I had set notifications for new version and i didnt get any. I had to update firewall by myself. Hope this is already been fixed.

That’s correct, they where only available for manual download, not for the inline updater.

Sorry, then what is the point of auto updater?

To release a version when it has a function, the previous 5.12 releases where only meant for Windows 8 users, it had no use to install those on lower Windows versions.

so, is there a fix for this ? I also have this - very annoying. Even simple console apps which don’t have any networking code trigger this igmp allert.

The changelog only lists Windows 8 related fixes. So there is no more use for this version as for the earlier 5.12 version to release it with the automatic updater.
And it seems, that there’s an issue with IGMP alerts as you can read here.

I have these IGMP alerts with all programs too since the last update (on Win8).
Very annoying.
I made a custom Global Rule to allow IGMP (from any address to 224.0.0.22 for IGMP) but it is never accessed.

I have this alert after upgrading to 5.12 on 7x64. Avira and other apps show this message. i will insert the global rule if for now there arent solutions. Byez

Hi,

I am a firewall engineer of COMODO, we will solve it in next version. in fact, getting alert about IGMP packet is normal, but usually this kind of packet is not important, so we will let it to be invisible for customer in future version. if you have any question, please reply message here or send private message to me.

Thanks,
Rick ■■■■

Thanks Rick :slight_smile:

Rick, thanks for keeping users informed.
When is this future ‘version’ expected, are you talking another update for CIS 5.12.
Seems this issue not fixed with update yet, a friend of mine is having the same issue/s ?
Thanks in advance for any info and expected update time :slight_smile:

I’m having this issue as well, but I’m also having a more annoying issue. IE9 has slowed to a crawl since the update. It takes about a minute for one simple page to load. I’m having to keep the firewall disabled just to browse the internet, which defeats the purpose of having Comodo in the first place… (Win7 x64)

Another thanks…

Please any news on update yet ???
Thanks :slight_smile:

So it seems that this question is exact same problem that is bothering me for over a week, i didnt noticed this question and asked about my problem here: https://forums.comodo.com/firewall-help-cis/big-amount-of-suspicious-icmp-out-connections-in-windows-7-t88516.0.html.

I’m somewhat relieved that this is “feature” of latest firewall version. I think firewall works at its best detecting whatever is defined by rules and happens to my network :P,

What im concerned/curious about is: why these connections has to be established and what is purpose of them. Where traffic of such kind has its and why it affects (almost?) every application. I’ve tried to disable various network and system things in windows just to stop these requests from reapearing, no success.

I have a workaround to not have this kind of alerts.

in firewall applications rules create a new rule for the file group “all applications”
to block (and register if you like) IP out from any address to any address when protocol is IGMP

Make sure that this is the topmost rule

I hadn’t side effects so far from blocking this traffic.