If you can not uninstall Comodo, please read this

Hi All,

This post is about how to solve in case you are not able to uninstall Comodo.

It is not a very common problem but something for which so far there is no one solution that may have worked for every one, the reason, it’s a complex thing, sometime you may have an installer / uninstaller interrupted so you may have incomplete installation or other time you may have messed around with various online tools in hope they may work but they may have actually complicated things further.

[s]So far we do not have any official tool to help solve such cases but simply use standard uninstaller option from Windows.

Till we can come up with any smart solution that may work for all or be able to guide you, we suggest following steps to be taken by user when he runs into this problem before he tries any other external script or tool:[/s]
Official Uninstaller tool released.
If this tool still fails and you still think you have Comodo installed and can’t re-install, we would like you to report bug in bug report section, providing following log files as input in post:

  • You will find log in same folder from where uninstall tool was executed
  • You need to find all logs from Windows temp folder (Windows Key + R and then type in %TEMP%) of following format:
    cmdinstall.exe_.log.7z
    cmdinstall.exe_
    .log
    COMODO *_uninstall.log

Step - 1: Collect msinfo32.nfo using msinfo32.exe:

  1. Go to Windows Run (Windows Key + R key in keyboard) and type in msinfo32.exe and press Enter key, it will launch System Information window application.
  2. Click ‘Save’ item in ‘File’ menu.

Step - 2: Collect Windows Event logs:

  1. Go to Windows Run (Windows Key + R key in keyboard) and type in eventvwr.exe and press Enter key, it will launch Event Viewer window application.
  2. Select ‘Windows Logs’ → ‘Application’ in opened window.
  3. Right mouse click on it ‘Save All Events As…’.
  4. Save as ‘Application’ events.
  5. Repeat steps 2-4 for ‘Security’, ‘Setup’, ‘System’ events.

Step - 3: Collect CIS installation logs:
Go to Temp folder in Windows by going to Windows Run (Windows Key + R key in keyboard) and type in ‘%temp%’ (without quotes) and press Enter key and find log file with naming convention as ‘cmdinstaller.exe_X_X.log.7z’ file.

Please provide above log files via personal message by sharing online link or attach to post, whatever you feel comfortable with.

After you provide above logs, team will analyze and if there are any suggestions, they will ask you to try and if finally nothing works, we will be happy to remote connect to your PC and try to solve the problem if you allow.

Thanks
-umesh

Umesh, here are the cmdinstaller.exe log files that I retrieved from windows key + R as directed. I am having no luck with installing CIS Premium 10.

Thanks, team will get in touch.

Why is Comodo taking so long to provide a fully supported uninstall tool? Users on this forum have been asking for it for years! Most of the other major security software packages have one. The excuse that “it’s a complex thing” is pathetic. The tool needs to be able to stop all CIS processes and services and then delete every CIS-related entry in the registry and every CIS-related file on the disk. Having an incomplete or corrupted installation of CIS should not matter - it would just mean that some registry entries and/or disk files may not be present so just delete the ones that are there so that all traces of CIS are removed. If you can’t identify all possible CIS-related entries to delete then there must be some VERY slack programming in CIS.

I have used the current uninstall tool after my CIS installation was ■■■■■■■ by the notorious in-line update. It generated so many errors I was amazed that I was able to reinstall CIS using the offline update. Although CIS now appears to work properly I still have 2 CIS entries in my list of installed programs. In contrast, when I used another security vendor’s official uninstall tool it just worked i.e. everything related to that product was deleted.

Hello, Who exactly do i message with the info you need. My computer networkadapters are totaly hosed at the moment and it wont let me uninstall comodo.

Hi Wolf_Digital,

Please upload the requested files in any online storage and provide us the download link through the private message.
Thanks in advance.

Kind Regards,
PremJK

Hello,

I sent a PM to umesh quite some time ago regarding this issue. I have not received a response. What should I do? Thanks.

Hi scooterbaga,
I have asked support to update the status.

Thanks
-umesh

I have the same issue and sent all the log file to umesh in a PM a while ago, but haven’t heard back at all yet.

Sometimes it happens that you can’t connect to the internet after uninstalling, using the unofficialclean up tool or trying a manual deinstallation. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

That will get the network connection up and running again.

Just create a restore point before installing CIS. When you restore your system, there are just a few folders and few other files left. You can find them easily with “everything”.
https://www.voidtools.com/

In next CIS release we are working on, CIS will create re-store point before installation and update and also we will be publishing official un-installation tool.

I will follow up further with team.

Great! :-TU

Decided to try out free firewall this morning, installed, and was asked to restart my pc.

Upon restart I was immediately locked out of the internet, all my admin rights were removed, I can not reinstall the program, I have no access to the windows control panel, I can not install anything new, I can not uninstall the firewall, I can not delete the registry keys, I can not stop the CmdAgent nor the cmdvirth services from the task manager, I have no access to my network settings, I can not reinstall windows, I can not reformat my hard-drive, I have no more rights to this computer, your software has effectively murdered my pc.

Now it’s 8:30 pm and I am exhausted.

Hi HelpMeOutPlease,
Sorry about that.

Seems serious conflict somewhere.
Can’t you login to Safe mode?

May you share version of Comodo Firewall you installed and OS name and version details?
Any other security software installed?

Thanks
-umesh

Hi and thank for your reply.

Got a little frazzled and my nerves were shot from troubleshooting into an abyss all day, needed some sleep.

Installer version I used was called mcd_fw_installer_6113_c7.exe

Anyways yes I can get into safe mode. Just got in, was able to uninstall comodo dragon browser. Next I tried to restart the network but I can’t seem to start the relevant services. Looks like all my connections were deleted from the place they are usually listed, so I can’t get into the properties and delete the firewall driver from there either.

Also in safe mode, I tried to set up a new user account with admin rights but it won’t grant them to me. Looked at my existing user profile and it says I am administrator - yet I have none of the corresponding actual rights. Managed to add a new user profile via cmd console - just as locked out on that one.

Can’t start any exe’s, even in safe mode. I’m writing this from an old win7 machine I managed to hook up to the net, not from the lobotomized win10 machine. I would really appreciate the help if you could guide me through what to do in safe-mode, it’s kind of beyond my level of kung-fu.

The machine that has been eviscerated is an Acer Predator tower i7-7600 32GB ram running windows 10 (home I believe but I can’t be 100% sure and there is no way I know of to check) & I was running Avira anti-virus on it. I can not uninstall or stop Avira from running now. I can not recover from a previous system-image. I can not reset to factory defaults. Hang on.

Hang on. No, After trying a second time, it seems I was able to restore from a previous system image after all. The damage is not fatal. I lost a bunch of 3d renders that took me hours to make, and I will have to reinstall all my programs.

All in all your software only cost me about 15 hours of work to get it the hell off my machine. The work lost with the renders destroyed in the process of doing so is about 20 to 30 hours, not counting artistic value. You came within an inch of doing some serious, and given my current situation, nearly irreperable damage to my life, I shit you not. I am seethingly furious at you in every way imaginable, but happy that it’s over and will avoid your products like the bubonic plague.

Judging by the previous posts in this thread, there are other people in line infront of me who might be suffering similarly due to your software. Know that your work can affect a life. You are making it way too easy for yourself with your quite frankly extremely shoddy & dodgy product.

Hello friends!
I have to agree with VsUK from this thread that this is a serious problem. And the number of reports seems to keep increasing.

I encounter almost the same issue for a THIRD time now. Everything started when I tried to uninstall CFW with a third-party uninstaller, which performed CFW leftovers scan and cleanup. After that system took too long to shut down, and when it rebooted, Windows failed to launch at all. All I could see was a blue screen offering boot/restore/diagnostic options, but those options didn’t work too – no system restore, no safe mode boot, no cmd.exe with admin rights as it couldn’t find any admin profiles.

This problem happened twice for me, and both times I used third-party uninstallers to cleanup CFW leftovers BEFORE reboot, and I guess this caused the problem. Whatever you guys do, NEVER EVER use third-party uninstallers to uninstall Comodo products. Always use Comodo native uninstall function via Windows Control Panel and reboot, and ONLY AFTER REBOOT perform leftover cleanups.

I cant say what exactly fixed the issue as I performed different tricks: dism health restore, sfc/scannow, some voodoo dancing, and nothing helped. But both times I succeeded to fix the problem I performed bootrec /fixboot, bootrec /fixmbr in cmd.exe and also booted from linux live usb system and copied files from C:/Windows/System32/config/RegBack (which seems to be a registry backup) to C:/Windows/System32/config/ (which seems to be current registry location). And only after that I could access admin profile from boot menu and use system restore point to rollback and only then reinstall CFW.

As the problem seemed to be caused by third-party uninstallers I believed everything will go fine if I don’t use them with Comodo products, but this time the issue started after using Virtual desktop. First, reseting sandbox took too long, so i had to shutdown that popup window manually. After that Windows Explorer started loading my CPU, so i relaunched it from Task Manger, but it kept eating CPU, though no active tasks or programs were running. I tried to reboot Windows, but it hang down with black screen for about 10 minutes, so I just forced shutdown with laptop power button. And now Windows doesn’t load again. This time it finds administrator profile, but cant find any system restore points, though several restore points were present in my system two days ago.

Aforementioned tricks that formerly fixed the problem do not help anymore as system cant find any restore points. No doubts that Comodo causes the issue. Some guy at Malwaretips forum reported similar result, which he caused intentionally in virtual environment for testing purposes by removing all trusted certificates from CFW Trusted Vendors list (along with those of Microsoft), after that his test system couldn’t boot too.

So I guess now the only way out for me is to reinstall Windows and all my programs and reconfigure it all to my preferences, which will take two ■■■■ days. Thanks to Comodo for an exciting eventful weekend.

While more or less tech savvy people can find solutions in some cases, the average user would end-up with a completely nonfunctional machine and would have to bring it to a maintenance workshop. And I believe this happens not only with free products, but payed versions too. How can you guys provide such a buggy software that causes so much damage and even take money for it!?

I made the paragraph structure more clear for an easier read. Eric

Hi,
We are trying to address this problem and in next major release due in Dec, 2017, in which we will have:

  1. System re-store point created before installation and update
  2. We will have official uninstaller.

We can’t go back in time but hopefully we can provide better experience down the road.

Thanks
-umesh