If * not put at beginning of WebFilter Rule Some Sites Are Not Blocked [M786]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Every time
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Add some links to be blocked (as shown in video and links are attached to this post)
    2:Note that some sites are blocked and some are not.
    3:Note that if * added to beginning all are blocked.
  • If not obvious, what U expected to happen:
    All sites added to the block list should be blocked if copied directly into block rule, as they would to navigate to the site.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    This happens even if the default lists to block Malware and Phishing are deleted.
    A video demonstrating this issue can be downloaded from here:
    It seems that if you add an * to the beginning of the sites they are all blocked correctly. This may be related to the problem.

[ol]- Exact CIS version & configuration:
CIS 7.0.315459.4132

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Default configuration
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Clean Install
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    win7,sp1,32bit in real system
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=none b=none

[attachment deleted by admin]

Could you attach a screen shot of your configuration?

Could you also let me know if it is only certain sites which cannot be blocked? For example, I know that currently it cannot block https sites.


hi chiron

This video shows the case

Does it happen with all executables? How about other file types? It looks like you are using a third party download manager. I wonder if that could be the cause?

Even with the loading of the browser and the same problem was also testing on another computer is also the same result

You skipped a couple of my questions.

  1. Does it happen with all executables (specifically direct exe links)?
  2. Does it happen with other file types as well?

Can you provide an example of a url that it fails to block for you?

If you disable the default malware and phishing site lists do any URL’s get blocked at all? If you have not already tried this, please do. I would like to rule out any possible issues with the rules created for the sites being tested.



Okay, in that case please attach a diagnostics report to your first post. Also, please send me a PM with the files containing the lists you used to check this. I will provide that to the devs for easy replication.

Once that is done I believe I can forward this to the devs.


I have modified the first post. Please look it over and let me know if all of the information is correct.


Alright, I can confirm that the url you provided is not blocked as entered. I found that if you change it to *d1a84k82uhn9mc.cloudfront.net/installers/cli/1395680487482/flvplayersetup-ncr81ee1u.exe it does block the site then. I use https everywhere and it even blocks it then only without ever displaying the page that says it blocked it. With https everywhere disabled it will block it with the Comodo message. But again, only if I enter it with the asterisk at the beginning.

Thanks to modify the topic
Information is correct

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Confirmed.I am experiencing this issue as well.

user405, thank you for letting us know that you are experiencing this as well.

does not fixed :-\

Thanks for checking this. I have updated the tracker.

The case has not been solved