If Dragon open virtualised in Desktop, it fails silently in Kiosk [M204] [v6]


  1. What you did: Opened Dragon using widget link, entered Kiosk using task bar link, attempted to open dragon from Desktop link, or Kiosk menu link
  2. What actually happened or you actually saw: Nothing, Dragon did not open, nothing to say why.
  3. What you expected to happen or see: Dragon opening
  4. How you tried to fix it & what happened: No fix
  5. If a software compatibility problem have you tried the compatibility fixes (link in format)? : Not a software compatibility problem
  6. Details & exact version of any software (except CIS) involved (with download link unless malware): N/A
  7. Whether you can make the problem happen again, and if so precise steps to make it happen: Happens every time using above steps
  8. Any other information (eg your guess regarding the cause, with reasons):

B. FILES APPENDED. (Please zip unless screenshots).:
0. A diagnostics report file (Click ‘?’ in top right of main GUI) Required for all issues): Appended

  1. Screenshots of the 6.0 Killswitch Process Tab (see Advanced tasks ~ Watch Activity) or 5.x Active Process List. If accessible, required for all issues:: Appended
  2. Screenshots illustrating the bug: N/A
  3. Screenshots of related CIS event logs: No relevant entries
  4. A CIS config report or file: Unaltered IS config, so not appended
  5. Crash or freeze dump file: Not appended
  6. Screenshot of More~About page. Can be used instead of typed product and AV database version: Not appended


  1. CIS version, AV database version & configuration: CIS 6.0 Build 2674, Database version 14816, Internet security config
  2. a) Have you updated (without uninstall) from a previous version of CIS: No uninstall then install using CIS 6.0 installer.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?: N/A
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a standard config (without losing settings - if not please do)?: N/A
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.): No
  5. Defense+/HIPS, Autosandbox/BBlocker, Firewall & AV security levels: HIPS=off, BB=partially limited, Firewall=safe, AV=Default
  6. OS version, service pack, number of bits, UAC setting, & account type: Win 7 Ultimate, SP1, x64, Uac=off, Admin
  7. Other security and utility software currently installed: Comodo Certsentry hard fail=on, Vmware workstation, Logmein, Clipmate, Raser keyboard configurator, Canon Network utility, Bluetooth configurator, Vmware, Filezilla server, WAR-FTP server, Routerstats, Acrobat, Comodo Ivault, FastStone capture
  8. Other security software previously installed at any time since Windows was last installed: None
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]: Installed on production

Link to files on FTP server:

Username and password as before. If you have forgotten them please consult the Mod’s Preview Board, Mod’s password sticky.

[attachment deleted by admin]

Can also confirm this in W7 64 bits, if any further details needed pls ask.



Can also confirm that this happens on Win7 32b. This is alimit of the VK / Sandbox aspect of CIS / D+ as the same thing happens with other browsers. :o

[attachment deleted by admin]

I can only replicate this issue with CD,
Firefox, Waterfox open fine, haven’t tried with Google Chrome…

[attachment deleted by admin]

So essentially, if Dragon if virtualized through the widget, and not closed at any time, opening the Kiosk and trying to open Dragon from inside the Kiosk does not work. Is that correct?

That is correct.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

I can confirm this same problem on Windows 8 x64 bit

Thanks for the confirmation

Please close the opened Firefox out Kiosk, then open Kiosk and open Firefox again.

Best Regards.

Can you please check and see if this is fixed with the newest version? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

This implies it’s intended, but I cannot see why. Could someone from QA explian please?

Meanwhile shall we leave open?

Best wishes


Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

You now get an error message suggesting to close the other instance which is fine. English not great, but we’ll let that be.

Please regard as fixed in 2487. Marked as such in tracker.

Thanks for checking.

I’ll move this to Resolved.