Iexplore.exe w/ firewall

Heres the situation…

Windows XP SP2 all up todate
Laptop w/ P4 Hyperthreading 3Ghz CPU
1MB ram

Ive had many firewalls in my professional and personal systems and networks, configuration isnt a problem but there seems to be a major problem with iexplore.exe and the comodo firewall.

because of the hyperthreading oh my cpu some applications behave oddly until you set the cpu affinity to use 1 processor exclusively. Ive done this and it still hasnt fixed the problem.

I noticed the problem when using windows live messenger beta 8.0, I click on my mail icon and it supposed to launch IE and auto login to read my mail, instead it launches the Iexplore.exe and the browser window never shows, if I click again it launches another iexplore.exe and hangs the same way.

I also noticed this problem in the comodo launch pad, if I click on the message to join the comodo forums it will hang, though this time I get a repetative alert I cant get rid of saying the other program is busy and get “switch to…” which pops up my start menu or “retry” which does nothing, I have to shutdown the launchpad from the task manager. The link from the launchpad should at least use the default browser and not IE exclusively, I have mine set for firefox, though Ive left my messenger to open IE for easy of use and avoiding useless password annoyances.

I like the features of comodo that Ive seen so far but this isnt a problem I can live with, I will have to uninstall it for now just to get things working well again, because who knows which other process and window launches this will interfere with, there is a tendancy in todays software to split applications and functions into seperate exes that launch one from the other.

If you can find the cause and propose a solution it would be great, till then I’ll have uninstall


1MB ram :slight_smile: whew. I hope you mean 1GB:) As for your problem, I’m sorry I don’t know.


CPF must work well with Hyperthreading and Multiprocessor machines.
We will try to reproduce this behavior and see what happens. But in the mean time, can you try to disable “Monitor OLE/COM Requests” and “Monitor Window Messages” options in “Security->Advanced->Application Behvior Analysis” section and retest this issue? Do you have any other security software installed?

Thank you for the cooperation,

We will try to issue an update which we believe will solve this issue, tomorrow(friday, 8/6/2006)



I don’t like that the CPF automatically starts IE when you click a link (eg. “join the forum” link) eventhough my default browser is FF. Is this just a problem with my machine or is it the default setting that CPF will launch IE as the default browser? How can I change it to not open IE and instead go to FF?