IE8 phoning home via HTTPS? [SOLVED]

Set up both firefox and internet explorer for local subnet access only (other access prompts).
Running Win 7 64-bit. When I launch firefox and browse to a local subnet served page,
all is quiet. However, when I do the same with IE8, it tries to start an HTTPS outbound
connection with some IP address in redmond.

I disabled CEIP in the control panel, but no joy, still phones home. Anyone know
what if any setting is causing this.

I know this is not a problem with Comodo, but I thought someone here might
know what’s going on. Is there a better place to ask this?

It may have to do with the Smart Screen Filter and antiphising features. IE maintains and updates those things through user input. I wouldn’t be concerned at all.

Yes, that was it. Shut off SmartScreen an no more unsolicited HTTPS. :-TU

But no more protection from SmartScreen. I would personally prefer to have that.