IE7 allow invisible connections?

My IE7 rules need “allow invisible connections” otherwise IE just shows - IE cannot display page.
Is this a security risk, why is it needed.

Using Avast and hosts file + edexter. I dont have the google download box problem that others have with Avast webshield, which is odd.

Is IE7 on the safelist yet? The details in application monitor for IE is:

c:\program files\internet explorer\iexplore.exe
Security Risk: Unknown.

Or maybe mine is infected, so its invisible? I have scanned with ewido and avast, its appears ok.

Also I disabled avast and edexter, and it still requires “allow invisible connections” to work.

CPF thinks its an invisible application, why?


Security Risk: Safe | Invisible: Ask
Connections: Unlimited

What is your IE v7 Build information?

CPF says:
Version: 7.00.5730.11

IE about box says:
Version: 7.00.5730.11IS

My thoughts are they probably slow getting around to adding IE v7.00.5730.11 to the safe-list…

Can anyone confirm whether IE7 needing “allow invisible connections” is a real risk. If so should I go back to IE6 for now?

What is the parent of your IE7 that requires “Invisible connections”? I am using IE7, same build as your, without “invisible” when the parent is explorer.exe (the normal case, I think). However, I have another iexplore.exe in which Firefox is the parent(!) and this requires that I allow invisible connections: this entry results from the Firefox context menu option “View this page in Internet Explorer”, sometimes useful for badly constructed web pages.

I do also have IE7 7.00.5730.11, and i don’t need to check the “allow invisible…” to get it to work.
It works fine, and the version number is the same in both CPF and IE.

I do have two rules for it. One with parent svchost.exe and one with explorer.exe


I disabled edexter, hosts file and avast and it still needs invisible to work. So that rules out any loopback reasons for it (if there could have been any?).

I have quite a few windows services disabled, I might see if enabling them fix it. I might send iexplore.exe to avast or someone to see if its infected or something. I know its likely to be me and not CPF.

I just created a desktop shortcut to “c:…iexplore.exe” and that works fine without “Invisible connections” enabled. CPF still sees its parent as explorer.exe as expected.

So its the installed iexplorer desktop icon that requires “Invisible connections” for some reason. It has the right click properties > Internet Options so it appears official.

I clicked allow so IE would work, assuming CPF is just questioning it because it’s a new version. No problems. (:TNG)

Many legit programs kick this off with invisible app accessing the internet. If I know it’s valid I allow it.