Identification of parent application not always correct

When a program, which is started by another program wants to connect to the internet, CPF (of course) asks if the program is allowed to because it has been started by another program.
However, sometimes I suspect the message is not correct. For example, Spyware Doctor is running at the moment. I get al lot of messages where CPF reports swdoctor.exe is the parent application. But I think, swdoctor.exe has nothing to do with it. Is this known behaviour? Or is swdoctor.exe for sure the application that started the applications? (I started Outlook to check my e-mail. Outlook uses stunnel to connect to gmail. But at the moment Outlook started to use stunnel, CPF asked it stunnel, with parent swdoctor.exe, was allowed to connect to the internet. But stunnel was already started when I started my computer and for sure, swdoctor.exe was not in memory at the moment I started my computer. And there is only one process ‘stunnel’ in memory)


I don’t have Spyware Doctor, so I’m just thinking out loud here, so bear with me.

Does SpywareDoctor have a memory resident component, like Spybot’s Teatimer? If so, is it possible that the memory resident stub is calling swdoctor.exe to check incoming data when Outlook attempts an outbound connection?

Just a thought, as I haven’t seen CPF get the parent wrong. Doesn’t mean it doesn’t happen, just that I haven’t seen it. :wink:

ewen :slight_smile:

Hmm, could be the case. I also just got a message that swdoctor.exe has altered some memory of stunnel.exe (or something like that), maybe the previous alerts were also about the memory. However, I remember I have wrong parent applications more often, especially when my computer is on full load and I want to start another program: Sometimes, CPF thinks another program is starting the program I just started. But I just tried to get such a message, but I did not succeed. As long as I can’t reproduce it and nobody else is experiencing this problem, ignore this topic (:KWL)

OK. Please keep an eye on this, though. As you say, it could be an intermittent bug that only occurs under reasonable load.

ewen :slight_smile:

Well, I got an example. I don’t know if it is normal, but when I load the downloads window of Firefox, there is some of delay. Has always been there, also before CPF. At the moment I load the window and thus Firefox freezes for a second or so and then (in the freezing moment) I press Start and E together (which is a shortcut for starting the Explorer), CPF tells me explorer.exe has tried to use firefox.exe through OLE automation. This is of course not true; I started explorer.exe and Firefox has nothing to do with that. I assume this is a bug?

No. Explorer.exe do communicates with it through OLE Automation.