ICS quit working after installing Comodo firewall

The two computers attached to my host computer can not retrieve a IP from the host and therefore will not connect to the internet and dont show up in my network places. already tried the define a new trusted network with no effect.

Did you also set the defined zone as trusted? This is needed to ensure intra LAN comms, including ICS.

Ewen :slight_smile:

how do you do that.

Well i uninstalled and re installed Comodo firewall then ran the new trusted network wizard again and my network is back but no joy on the client computers connecting to the internet.
The host computer connects to the internet with no problem.

If youve got CFP installed on the other PCs, then you should runthe trusted network wizard on them as well.

Hope this helps,
Ewen :slight_smile:

i didn’t install Comodo firewall on the other computers but i did turn off the windows firewall on them and on the network card that they are attached to.

G’day,

The first thing to check is whether the other PCs can connect to the internet if you set the firewall on the ICS host PC to “Allow All”. If they do, then its either a rules issue on the host PC or its possibly a timing issue to do with DHCP.

Do your PCs have static IP addresses or do they get their IP address automatically?

To check this, do a right click on “My Network Places” and select PROPERTIES. This will open the Network Connections window. Do a right click on the icon for your LAN connection and again select PROPERTIES. In the PROPERTIES window, scroll down the list until you can see TCP/IP. Do another right click on this and select PROPERTIES. This will show the properties of the IP protocol.

If it has numbers in the “IP Address” field, then you have a static IP address. If, on the other hand “Obtain an IP address automatically” is select, then you are using what is known as DHCP to assign addresses automatically.

If you do not have static IP addresses, you could try turning all PCs off and then turn just the ICS host computer on. Once the host PC has completed booting and you can access the internet on it, try turning on one of the other PCs. Once it has completed booting, check whether it can now access the internet.

Let us know how you get on.

Cheers,
Ewen :slight_smile:

I set CFP to “Allow All” and no joy, then i checked to see if the other PCs had static IP addresses and they don’t they are set to “obtain an IP address automatically” the host computers network card that hooks to the Internet is also set to “obtain an IP address automatically” the network card in the host thats hooks to the other computers does have numbers in the PROPERTIES by the “IP” and “subnet mask” the “default gateway” is blank. the “DNS server addresses” is ticked, the “preferred DNS server” is blank and the “alternate DNS server” is also blank.

Then i did the restarting the computers as you suggested and that worked, everything seems to be working.

Another couple questions: i wonder if i should put CFP on the other computers as i went to “shields up” with both client computers and got a perfect stealth rating.
Also I have cable internet which is very fast but with this firewall running things have really slowed down to like when i was on 56k dialup, is this because of the learning mode the firewall is in or is it having problems with the amount of bandwidth i use (between 15 to 30 Gigabytes per day).

Thanks for all the help Ewen

If its working when you boot the ICS host first and then the clients, I would assume that its a timing issue in the clients PCs being assigned an IP address.

Performs like a 56K modem? Learn mode will place a slight (very slight) overhead on throughput, but not to the point where it’s lke dial-up. The firewall shouldn’t really be concerned with the quantity of incoming data and it shouldn’t overly affect your download speed, unless you have an excessive amount of logging going on.

Please check your CPU utilisation and memory usage in Task Manager and post the results back here.

Please also check your firewall logs and see if they are recording excessively.

Does the speed go back up if you set the firewall to “Allow All”?

Cheers,
Ewen :slight_smile:

CPU utilisation and memory usage in Task Manager
“cpf.exe 1% CPU 23648K mem 19486VM”

This memory usage shouldn’t be a problem as there is 3Gig of RAM on computer.

Does the speed go back up if you set the firewall to “Allow All”?

Slightly, appears to have been a problem with my ISP as it is working much better now.
Need to remember that little trick (set the firewall to allow all)

Thanks again for all the help Ewen

Just remember, TLD, when you set it to “Allow All” you are bypassing the firewall entirely; it’s like you don’t have one at all… So you can use it to check stuff like that out, but make sure you turn it back to “Custom” ASAP.

LM

I’ll keep that in mind Little Mac.