ICMP and Failed GRC

I just installed v 2.4.18.184, as a replacement for Windows FW on XP Pro (which blocks pcAnywhere, regardless of any attempts to modify it to allow pcA).

When I run ShieldsUp at GRC, everything passes EXCEPT the ICMP (ping)! I’ve tried to block all ICMP by creating rule(s), to no avail. I also need to allow pings on my LAN, and my customers’ LANs, but block pings fron the internet.

I read an older post regarding GRC & ICMP, about this, but it doesn’t seem to apply. Any help would be appreciated… THX

Greetings,

I guess you’re using a router?
If that’s the case, GRC is testing the router and not Comodo Personal Firewall.
Then it’s your router that’s stealthing the ports, but not blocking ping(ICMP echo requests).

Ragwing

You need to allow that ICMP that grc.com reports because that’s the only way your ISP can verify when you’re online.

(L)

:BNC

well i just went to that site too?, i’m on verizon DSL,
it passed all the test but that icmp ping test thing

http://www.grc.com/x/ne.dll?rh1dkyd2

well, so if it does not pass that one thing,am i still protected ?.

Posted in kissababy’s topic…