IceDragon not recognizing Local Hostnames

I am using Windows 7 on a home network.

Each computer/NAS/Network device on my network has a name. For purposes here lets say they are each named after planets. My computer is Jupiter, my wife’s is Saturn, the 3 Synology devices are Uranus, Neptune and Mercury etc.

In Firefox, when I type Neptune:5000 in the address bar, I get the web interface for the NAS server I have named Neptune. However, in IceDragon, when I type Neptune:5000, the browser does a Google search for Neptune. If I type Http://Neptune:5000 it takes me to In either browser, if I type the internal IP address ( I get the correct host computer/device.

Is this a bug or is IceDragon designed to ignore Local Host names for some reason? (note the same thing happens in Comodo Dragon but not in Chrome)

Hi Dragonsdream,
Please try disabling ‘malware domain filtering (Comodo Secure DNS)’, found under the general tab of the advanced options in IceDragon.

In Dragon the setting is found under privacy in the advanced settings.

Kind regards.

Thanks for the reply
However, I never had that turned on, so that’s not it. I have tried going through the about:config setting and comparing them to my Firefox settings and can find no differences that would cause this behavior. Is this a bug then if this is not intended?

Hi Dragonsdream,
Sorry my advice didn’t help and I have no other ideas of what could be causing this behaviour.
As you say it could very well be a bug and for this reason I have asked Staff to take a look at this topic.
Note: Staff will only reply when time permits, thanks.

Kind regards.