IceDragon keeps freezing up

Hey everyone. I have not been able to use Comodo IceDragon very much at all for the past couple of weeks because after I’ve browsed the internet for a short while, it starts freezing up. Usually it comes out of the freeze on its own but it freezes up repeatedly and this is very very annoying. I am able to use Comodo Dragon on my computer just fine but Comodo IceDragon is very problematic because of this.

Here is the information from the troubleshooting tool in Comodo IceDragon:

Application Basics ------------------

Name: IceDragon
Version: 26.0.0.2
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 IceDragon/26.0.0.2

Extensions

Name: Adblock Plus
Version: 2.5.1
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Dictionary Extension
Version: 3.0.12.1
Enabled: true
ID: jid0-raWjElI57dRa4jx9CCiYm5qZUQU@jetpack

Name: DragAndDrop
Version: 26.0.0.2
Enabled: true
ID: DnD@comodo.com

Name: LastPass
Version: 3.1.1
Enabled: true
ID: support@lastpass.com

Name: WOT
Version: 20131118
Enabled: true
ID: {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}

Name: Xmarks
Version: 4.2.5
Enabled: true
ID: foxmarks@kei.com

Important Modified Preferences

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.places.smartBookmarksVersion: 4
browser.search.useDBForOrder: true
browser.sessionstore.upgradeBackup.latestBuildID: 20131218181224
browser.startup.homepage: http://www.newadvent.org/|http://greatergood.com/
browser.startup.homepage_override.buildID: 20131218181224
browser.startup.homepage_override.mstone: 26.0.0.2
browser.tabs.loadInBackground: false
dom.mozApps.used: true
extensions.lastAppVersion: 26.0.0.2
gfx.direct3d.last_used_feature_level_idx: 1
keyword.URL:
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1394530560
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1393833001

Graphics

Adapter Description: NVIDIA GeForce 9100
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 256
Device ID: 0x0847
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 12-19-2013
Driver Version: 9.18.13.3221
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x10de
WebGL Renderer: Google Inc. – ANGLE (NVIDIA GeForce 9100 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0

JavaScript

Incremental GC: true

Accessibility

Activated: false
Prevent Accessibility: 0

Library Versions

NSPR
Expected minimum version: 4.10.2
Version in use: 4.10.2

NSS
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC

NSSSMIME
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC

NSSSSL
Expected minimum version: 3.15.3.1 Basic ECC
Version in use: 3.15.3.1 Basic ECC

NSSUTIL
Expected minimum version: 3.15.3.1
Version in use: 3.15.3.1

Here is my System Information:

OS Version: Microsoft Windows 7 Home Premium, Service Pack 1, 64 bit Processor: AMD Athlon(tm) II X2 215 Processor, AMD64 Family 16 Model 6 Stepping 2 Processor Count: 2 RAM: 4863 Mb Graphics Card: NVIDIA GeForce 9100, 256 Mb Hard Drives: C: Total - 599384 MB, Free - 535473 MB; D: Total - 10992 MB, Free - 1649 MB; Motherboard: PEGATRON CORPORATION, VIOLET6 Antivirus: COMODO Antivirus, Updated and Enabled

I have tried resetting Comodo IceDragon to its default state in the Troubleshooting Information tool. I have also tried uninstalling and reinstalling Comodo IceDragon. I remember for certain that uninstalling and reinstalling Comodo IceDragon was to no avail. I cannot recall exactly what happened after I reset it to its default settings/state. I do remember that after uninstalling and reinstalling it, everything remained exactly the same. All of my bookmarks, extensions, and everything remained exactly the same.

I would greatly appreciate some help.

Hello,

As lamda-user, it can be be a malware , or maybe flash (bug 01-2014 corrected)
Flash video (for example YouTube) causes IceDragon (18.0.1.0) to freeze when Comodo Internet Security (6.0.260739.2674) HIPS setting is set to Paranoid or Safe mode in Windows 8 x64.

cloud based system _ detect & remove malicious program.

Thx.

It’s possible that your add-ons may be causing your problem.

I noticed you are running the latest versions of Xmarks & Lastpass. Normally for software that would be a good thing, but in the case of add-ons, it can cause problems. You should only be running the latest version approved by Mozilla and even then you may still have problems.

Try uninstalling Xmarks & Lastpass. The latest approved version of Xmarks Sync is 4.2.1. You can get it here: https://addons.mozilla.org/en-US/firefox/addon/xmarks-sync/?src=ss

The latest approved version of Lastpass is 2.0.20. Get it here: LastPass Password Manager – Get this Extension for 🦊 Firefox (en-US)

Go here: LastPass Password Manager version history - 25 versions – Add-ons for Firefox (en-US)
and you can see that version 3.1.1 of Lastpass is still being evaluated by Mozilla; hover your mouse pointer over version 3.1.1 and a yellow caution button appears to the right.

Adblock Plus version looks okay. DragAndDrop automatically updates with the browser. WOT version looks okay. Your Dictionary Pop-Up extension v3.0.12.1 looks okay.

The safest way to update your extensions is to click on the gear button in the upper right of the Add-ons Manager window and select ‘Check for Updates’. If there are any new updates available, ‘Available Updates’ will appear on the left side. You can click on that and then review your updates. You can also view the release notes for each add-on extension to help you decide if you want to update it.

Let us know if that helps.

gs22

Just a followup. If you are still having problems after trying the suggestions mentioned previously, then disable all your add-on extensions. If your problem goes away, then enable one extension at a time until the problem returns. Disable the problem extension and continue checking the remaining extensions.

Hope that helps.

gs22

Just a followup to help new readers so they are not confused by my previous comments.

The latest approved version of Lastpass is now 3.1.1 as of 5/8/2014, which requires me to explain my next comment which is no longer valid.

At the time of my original comment (3/13/2014), the yellow caution button
http://button.jpg
(see image below) was active. It is now green. According to Mozilla, the yellow caution button means a Preliminary Review was done which is a faster review intended for experimental add-ons. Preliminary reviews do not check for functionality or full policy compliance, but the reviewed add-ons have install button cautions and some feature limitations.

Also, according to Mozilla, add-ons that have had a Full Review receive a green install button. Full reviews are appropriate for add-ons that are well-tested, stable, fast, and have wide appeal to our users. We aim to perform full reviews in under 10 days, though most add-ons are reviewed in much less time.

Not sure why but the latest approved version of Xmarks Sync is still stuck at 4.2.1.

gs22

[attachment deleted by admin]