Ice Dragon

Have installed ice dragon but won’t open. Any suggestions? Tried uninstalling and re installing, no luck. This is ver 22. Is there a download link for an earlier version? We have Dragon installed and that works fine ( 27.2 )

Did you try to install as Administrator.?
Try to install the portable to any folder.
Previous version here.

Yes I’m the admin and installing the portable yields the same result. Also the link sends me to the ver 22 download not the previous version, thanks. I wanted to try and older version to see what happens. I recently installed ver 22 in another machine and no problems. I also uninstalled Dragon (27.2) and re downloaded it and no problems with re installation and operation. Weird.

Hi safari801,
Try the below link for the previous version.
IceDragon V21

You did not follow the link - on.

Ver 21 does the same, won’t open. Strange that Dragon works fine but not so ice dragon.

Your try to install the portable to any folder?
Edit: Yes I saw. Tried it.
Place the folder (with portable CID) in the C: Where folders Programe Files etc.
Send a shortcut to the desktop.
What do you see when you start a CID?
Edit: Disable all add-on.
Check the not blocking anything CID.
If you reinstall, remove all traces and profiles.
Related to the CID.

Yes that worked Jenny66, thanks for the help.

I have the same problem as outlined above including v21 but excluding the July 14 post and have tried all possible (that I can think of) installation methods. [WinXPSP3]
I can get it to run sometimes but that is achieved by clicking rapidly about a dozen times???

Fortunately I had a copy of v15 which works perfectly but after it auto-updates or manually updates, the updated version will not run.
I can then re-run the v15 installer and normal service is restored.
Sometimes, IceDragon will run once if the ‘run now’ box is ticked in the installer but this appears to be unpredictable.

Ideas welcomed.