Ice Dragon v44 is now available to download

Hello everyone,

We’re very pleased to announce the release of Ice Dragon v44.0.0.11

What’s new?

  • Firefox code base has been updated to 44
  • Fixed! Race condition can cause attackers to implant dlls - Reported by Greg Linares of CyberPoint SRT
  • Fixed! Updater can be used to execute unsigned files - Reported by Andre Derek Protas of CyberPoint SRT

Download Location

MD5: 9dbcfe5597c6e2ed0e0dd3ea83f668fc
SHA-1: f647ad3d541f828bec3c731268fdba7d963b205d

Thank you for your all feedback for COMODO Browsers! We have collected all of your feedbacks and created a list of improvements and new features. We really appreciate all of your contributions to provide you a great browser.


Comodo Ice Dragon Team

Since version 38 every time you bring out an update and say click to download in the browser and restart it KILLS my CID. I use the portable version, after version 42 i stated this problem and you said you would look into it. Clearly you are not testing things properly for this to be a constant issue. I even know someone with dragon that updated and it killed their browser too. Your updating process is highly flawed.

This is what happens to my portable CID file directory after clicking update and install… it deletes most of the files and will not run. Having to install the new version from scratch and get all my settings and customization back is a real pain. It takes over an hour and annoying process. I am considering looking into an alternative portable browser as this is so annoying! Test properly. I hate to leave comodo, but your update process is useless.

Edit: you might think this is caused by some addon I have, like a firefox extension installed, I can assure you it is not. I have learned to make several copies of the CID portable directory when I install it, and have a clean copy from when 42 was installed as portable months ago… that also fails to update and does the same thing in my screenshot. I cannot update CID portable from the browser, it just destroys the directory. This has been tested on several machines. I work in IT, I am making sure it’s not user error, and I cannot see it being that. I suggest your team gets a copy of 42, install it as portable and then try and update it from the browser. If that works for you, I’d be surprised. You focus on full install, not the portable users.

I am bringing in this post from another topic as it seems better fitted here:

Try running the installer from the topic start. It will provide version 44. Let us know if that fixes it or not.

Thanks guys, installed ok with no problems here. Is there a link you could possibly give me to find what the changes are? :slight_smile:

The installer in the OP worked, but I received two warnings.
Here’s the first one below and the second one was something similar (“wow…” “kernel32.dll”)

On what Windows version are you?

XP. I didn’t mentioned it, because I thought that it was implied in that thread. You’re right, it was confusing. So, it was XP. By the way, I was thinking about that earlier and could it be because icedragon_updater.exe was turned off at that time? At this time, About ID reports running Also, I confirm that automatic downloads work fine on my other machine running Windows 7.

Looking at the classic UI style I figured XP but I wanted to be sure. The alert you are getting implies something 64 bits in the situation when it mentions “WoW64RevertWoW64FsRedirection” . Are you on a 32 or 64 bits version of XP?

Was the installation successful by the way?

I saw the same 64bit error messages as thevillager, running XP SP3 on a 32bit laptop.

After the built-in updater failed I installed from the Windows/Temp directory, but didn’t trust the install after seeing those errors. I uninstalled CID.

Then I downloaded the v.44 exe file from the link above, and ran that. Saw the same 64bit errors.

Now, going to ‘About Icedragon’ shows me running v. but the ‘Checking for Updates’ whirlygig does not stop circulating.

Thank you for reporting. It looks like something is up with the installer.

Yes, the installation was successful. I am running XP 32 bits. The classic UI shell is because I like it old school. :slight_smile:

Thank you for the new version. Will we have to wait very much for a version for multilanguage?, ¿ or is it possible to put this version 44 in Spanish? If it is like that since it is done?
Thank you very much

It’s in the works but we don’t know a time line.

Is anybody having problems with the Help → About IceDragon constantly checking for updates for a long time? Is this a problem or is it suppose to do that?

[attachment deleted by admin]

Please check in Services (Control Panel → Administrative Tools) if the COMODO Dragon Update Service is running .

Nope, the Comodo Ice Dragon Update Service isn’t even there!

Are you running CID portable or did you install it?

I installed it using the exe from the temp folder.

Try installing CID again and see if that fixes it or not.

Tried it doesn’t fix my problem with Help → About IceDragon Update