Ice Dragon Running FV Does Not Have Option To 'Stop Virtual Mode' [M957]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Yes, every time I am in Ice Dragon’s virtual mode I don’t have a ‘Stop Virtual Mode’ option, the options still show as ‘Start Virtual Mode’ and on clicking the icon or menu option it just restarts Ice Dragon in Virtual mode again.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Start Ice Dragon, click on the icon to take me to Virtual Mode.
    2:Usually to exit virtual mode I click on the icon again which should now have a tooltip of ‘Stop Virtual Mode’ and Ice Dragon closes and reopens in normal mode with the tabs open that I was previously using.
    3:But now, clicking the icon or menu option that usually exits virtual mode causes Ice Dragon to close and again reopen in Virtual mode. I have to close the browser fully and restart it normally to exit virtual mode. This means my browsing session in normal mode before going into virtual mode will be lost.
  • If not obvious, what U expected to happen:
    To exit Ice dragon’s virtual mode and be back in normal mode with my previously opened tabs etc.
  • If a software compatibility problem have U tried the conflict FAQ?:
    No I don’t think that is the case. It is also happening on a friends computer.
  • Any software except CIS/OS involved? If so - name, & exact version:
    No, nothing has changed apart from a recent update to CIS.
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I’ve tried deleting the virtual mode files for Ice Dragon (C:\VTRoot\HarddiskVolume1\Users\me\AppData\Roaming\Comodo\IceDragon\Profiles) and also started Ice Dragon in safe mode but the problem persisted.

[ol]- Exact CIS version & configuration:
CIS 7.0.315459.4132. Configuration: Comodo Internet Security.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    AV and Firewall, Auto Sandbox unknown apps as partially limited.
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
  • Have U imported a config from a previous version of CIS:
  • OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 Ultimate 64 bit, Windows Defender turned off and full administrative use. The problem was also seen on another computer using Windows 7 Ultimate 32 bit.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

[attachment deleted by admin]

Did this work differently before the update to CIS version 7.0.315459.4132?

By that I mean did you used to have CIS version 7.0.313494.4115 installed and at that time it worked fine with Ice Dragon virtualized?
If so, then did Ice Dragon also recently update on your system? This really sounds like a bug in Ice Dragon and not in CIS, so I want to clarify this.


Hi ya. Yes it was fine before the recent update to CIS. Actually a friend brought it to my attention when she told me that in virtual mode when she went to click on ‘Stop Virtual Mode’ via the Ice Dragon main button and menu it was still saying ‘Start Virtual Mode’. She also told me that when entering Virtual Mode she didn’t get that usual web page explaining to the user that they had entered Virtual mode etc. I then looked at my Ice Dragon and found the same thing to be happening, and found I couldn’t quit Virtual mode without exiting the browser completely. I haven’t used my PC for several days due to work commitments which is why I have only just noticed it. There hasn’t been any updates to Ice Dragon and I haven’t made any changes either. Considering that the Virtual Mode is linked to having CIS installed I put 2&2 together and thought it must have been the recent update. It was definitely fine before that, I regularly use Virtual Mode without problems, only after the last CIS program update has it not worked, and it’s the same on my friend’s PC. I use Windows 7 64 bit, my friend uses Windows 7 32 bit and she also uses Virtual mode regularly and noticed it before me.
Thanks :slight_smile:

Okay, now I understand. Please edit your first post so it is in the format provided here.

If you have any questions please feel free to ask.


Ok I’ve done that, thank you :slight_smile:

Thanks. Please also create a diagnostics report while Ice Dragon is running virtualized. Then attach the diagnostics report to your first post.

Let me know when you have done this, or if you have any questions.


Ok. Would that be a diagnostics report using Windows built in Performance monitor (perfmon.exe)?

No, it is a different kind of diagnostics report. To create this diagnostics report open the main CIS GUI. Then left-click on the question mark icon (near the upper right corner). From here select Support and then Diagnostics. This will run the diagnostics and give you the option to create the diagnostics report. Please do create it, then attach it to your first post.


Ah ok nice one. I’ve done that now. I ran Ice Dragon in Virtual mode like you asked whilst running the diag tool and attached the zip file.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

You’re welcome. Thanks for the fast responses :slight_smile:

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

Hi Chiron. I’ve just installed and applied any updates to CIS and I am running version However the problem is still there, it still says ‘Start Virtual Mode’ when actually in virtual mode instead of ‘Stop Virtual Mode’, and I have to fully close Ice Dragon to be able to get back to normal mode.
Thanks for letting me know of the updates anyway.

Thanks for checking this. I’ve updated the tracker.


The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version and let me know if this is fixed on your computer with that version.

Thank you.

Hello wasgij6
I can confirm that the problem remains with CIS version
Thanks for your reply.

I have updated the tracker.


Newer versions of Ice Dragon no longer provides the option to enter or stop virtual mode within the menu so moving to outdated/resolved issues.