Ice Dragon not able to surf local servers

I am using Ice Dragon and have it set to use Comodo Sercure DNS (Ice Dragon Only). This has been a recent development. None of my local servers have www or com on them and Ice Dragon puts them there. I suspect that it does so because it can’t locate the server under the real name.
I have turned off the Secure DNS in Ice Dragon and it makes no difference. I have diabled all add-ons. Still doesn’t work.

It does work in IE and Firefox and Comodo Dragon.


Did you flush the DNS cache after switching DNS servers? Does restarting CIS make a difference?

I tried to access my router using CID and that worked. Using Win 8 x86.

When you disabled all add ons did you do that from within the interface? Or did you use “Restart with Add-ons disable”? What is the result if you use both strategies?

I haven’t tried restarting with add-ons disabled. I did put a local server in my hosts file and it failed. Is the host file not the first place everything looks anymore? If I use the Ip address it goes just fine. For some reason my CID isn’t resolving hostnames via the normal path. Comodo Dragon does as well as IE and the other browsers I have installed. Including Firefox.

Just an FYI, I never did fix this. But I have recently had to go back to Windows 7 from Windows 8. I have formated the drive and started over. Icedragon never will connect to my local webservers. Dragon, Firefox, IE all connect. I have a feeling that Icedragon is using ComodoDNS servers, even though I told it not to.

Where can I change that or is it hard coded into IceDragon?


Hi Raeldin,
The setting is found under advanced, general, system defaults in the 'Advanced Settings.
To disable, uncheck “Enable malware domain filtering (Comodo Secure DNS)”.
Configuring Advanced Settings

Kind regards.

Sorry Cap’n it is already unchecked. Any other thoughts? This worked until a few (1) weeks before I posted this the first time.

Thanks for the help.

Which firewall do you use?
See if there is a locked?
Try CID portable.
Set to any destination. Installation of the system is not needed.
See also.

Hi Raeldin,
Other than checking the connection settings in CID (Maybe compared to FF), I am not sure what to suggest sorry.
Connection Settings
So everything is still fine with the other browsers?

I am using Comodo firewall. I’ll try the portable and also compare settings to FF. And yes all browsers but CID work fine when accessing my local network.

Still haven’t compared settings but… I got this smart idea that I would install fiddler and find out exactly what is going on.
If I run fiddler and attempt to go to a local network site, it works fine. Fiddler shows me requesting and receiving the page. If I go without fiddler running it won’t go. I get a yahoo can’t find page instead.

Go figure.

I have set browser.fixup.alternate.prefix to blank and browser.fixup.alternate.suffix to my domain name. This works. For some reason CID is not handling the url correctly when it is on the local network. This will probably be a pain and I may remove it but for the moment it gets around a stupid bug.

Try Firefox and see if you have the same problems. If so then the problem might be with the Firefox code.

As stated above Firefox works fine. As do all of the other browsers I have. In fact CID worked until just before I made the original post. It hasn’t worked since. I have been using IE to hit local websites but finally decided to try this and it worked. I have even formatted my drive, and reinstalled everything and still CID wouldn’t work.

Also I should mention that I changed my host file and placed one of the servers in there. This did not work unless I explicitly added my domain to the file.

This may be a bug. Please consider submitting a bug report on this.

Maybe I am just being dense or blind or something, but I can’t find where to submit the bug report.

with these information

  • Your Operating System (and whether it’s 32bit/64bit);
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • Any other Additional Information;

You can open a new topic for a bug HERE :-TU