Ibnet Player simulazione di volo

Ciao a tutti,
intanto grazie mille per l’ottimo supporto che date per il firewall Comodo (gran prodotto secondo me).

Ho un problema con la configurazione di IBnet player ( http://www.ibirdsoft.altervista.org). Si tratta di un softwarino che consente la simulazione di volo in formazione in modo molto realistico attraverso FS2004.

Lavora in accoppiata con Hamachi (già configurate le regole trovate sul forum).

Ora sul sito del produttore è indicato di aprire le porte Udp/tcp 2003, 2004, 2006.

Ho cercato di seguire le istruzioni ma sbaglio sicuramente qualcosa nella configurazione di Comodo: risultato gli altri giocatori vedono me ma io non vedo loro a meno di non disabilitare completamente il firewall (cosa che vorrei decisamente evitare).

Mi rendo conto che si tratta di un problema inusuale e magari anche un po’ di nicchia ma magari qualcuno può darmi qualche dritta.

Grazie mille,

Max

Ciao Max :slight_smile: benvenuto nel forum.

Sai se le connessioni richieste sono solo Out oppure anche In?

Comunque vai in FIREWALL==>> Common Tasks==>> My Port Sets==>> Add…==>> A new port set==>>gli dai un mome ad esempio Ibnet ports==>> Apply==>> vai sul set di porte appena creato click col tasto destro==>> Add… ed aggiungi una ad una le porte 2003, 2004 e 2006.
Fatto questo vai nell’Application Rules trovi l’applicazione Ibnet Player la selezioni==>> edit==>> Add… e fai questa regola:

Action = Allow
Protocol = TCP or UDP
Direction = Out
Description =
Source Address = Any
Destination Address = Any
Source port = Any
Destination port = (A Set of Port) = Ibnet Ports

Se non dovesse andare mi trovi sempre qui :wink:

Ciao Sirio,
grazie mille per la risposta.

Ancora non sono riuscito a risolvere: ho seguito le tue istruzioni, credo che tuttavia la comunicazione sia in e out.

IBnet Player trasmette la mia posizione agli altri e viceversa, dal simulatore.

A naso siamo comunque sulla strada giusta, almeno credo :).

Da quanto ho letto sul sito del produttore (non è molto chiaro) 2003 e 2004 dovrebbero essere UDP e 2006 TCP/IP.

Non riesco a capire quali ricevono e quali trasmettono.

Sicuramente è un problema col firewall poiché se lo disabilito tutto funziona.

Se trovassimo una soluzione uno sparuto gruppo di malati per il volo te ne saranno super grati!

Ancora grazie,

Max

Bene Max… tenteremo :wink:

Avrei bisogno del link dove descrivono le porte da aprire e i protocolli da usare. Potresti postarlo per piacere?

(:WAV)

Ciao Sirio,
Questo il link del loro forum in generale: IbirdSoft.com is for sale | HugeDomains

Un po’ di link vari sui problemi di connessione sempre dal loro forum:

http://www.ibirdsoft.com/forum/viewtopic.php?t=166&highlight=configurazione+firewall

http://www.ibirdsoft.com/forum/viewtopic.php?t=241&highlight=configurazione+firewall

http://www.ibirdsoft.com/forum/viewtopic.php?t=229&highlight=configurazione+firewall

http://www.ibirdsoft.com/forum/viewtopic.php?t=204&highlight=configurazione+firewall

http://www.ibirdsoft.com/forum/viewtopic.php?t=168&highlight=configurazione+firewall

Ho provato con connessione 56K, UMTS (quella che uso di più), ADSL. Sempre lo stesso risultato.

Volo abitualmente in rete sul network IVAO usando Teamspeak e altri tools senza problemi attraverso Comodo.

Sei troppo gentile: non diventare matto più di tanto comunque :slight_smile:

Grazie,
Max

(:WAV)

Forse ormai è troppo tardi… ;D

Grazie, Max

(:WAV)

Ho dato uno sguardo ai link e ho fatto queste altre regole:

Regola 1

Action = Allow
Protocol = UDP
Direction = In
Description =
Source Address = Any
Destination Address = Any
Source port = (A port range) 1024-65535
Destination port = (A port range) 2003-2004

Regola 2

Action = Allow
Protocol = UDP
Direction = Out
Description =
Source Address = Any
Destination Address = Any
Source port = (A port range) 2003-2004
Destination port = (A port range) 1024-65535

Regola 3

Action = Allow
Protocol = TCP
Direction = In
Description =
Source Address = Any
Destination Address = Any
Source port = (A port range) 1024-65535
Destination port = (A single port) 2006

Regola 4

Action = Allow
Protocol = TCP
Direction = Out
Description =
Source Address = Any
Destination Address = Any
Source port = (A single port) 2006
Destination port = (A port range) 1024-65535

Regola 5

Action = Block (attiva l’opzione Log as a firewall event if this rule is fired)
Protocol = IP
Direction = In/Out
Description = Blocca e registra tutte le richieste che non corrispondono
Source Address = Any
Destination Address = Any
IP Details = Any

Una volta applicate queste regole ad Ibnet, quando proverai, il Firewall Events (log) registrerà gli eventi bloccati utili per capire cosa eventualmente non va, quindi salvati il log così nel caso puoi mostrarmelo per correggere le regole.

Forse ci sarà bisogno di cambiare anche questa impostazione però non è detto, prova: Vai su Firewall==>>Advanced==>>Attack Detection Settings==>>Miscellanous e disattiva l’opzione Block Fragmented IP Datagrams.

(:WAV)

Ho solo due parole: SUPER GRAZIE.
(:CLP)

Venerdì sera ho l’appuntamento con gli altri per un volo: formazione acrobatica “Frog” con i vecchi F104 . O0

Ti posterò subito i risultati.

(:WAV)

Max

Di nulla :slight_smile:

Dimenticavo: per far si che le regole funzionino, nelle Global Rules la regola di blocco deve essere Block And Log ICMP In from IP Any to IP Any where is ICMP message is ECHO REQUEST

Ok, modificata.
Domani provo e ti dico.
(:WAV)

Max

:BNC

Funziona!!!

Grande Sirio!

Scusa se rispondo un po’ in ritardo ma volevo essere ben sicuro: ho fatto diverse prove di connessione su vari server e reti vpn create con Hamachi.

Caspita per ora funziona tutto alla grande.

Mitico. Grazie,

M

(:CLP)

(:WAV)

:■■■■…mi fa piacere Max. (:KWL)
Hai dovuto togliere il flag su Block fragmented IP datagrams?

Puoi provare a restringere ancora così:

Regola 1

Action = Allow
Protocol = UDP
Direction = In/Out
Description =
Source Address = Any
Destination Address = Any
Source port = (A port range) 2003-2004
Destination port = (A port range) 2003-2004

Regola 2

Action = Allow
Protocol = TCP
Direction = In/Out
Description =
Source Address = Any
Destination Address = Any
Source port = (A single port) 2006
Destination port = (A single port) 2006

Regola 3

Action = Block (attiva l’opzione Log as a firewall event if this rule is fired)
Protocol = IP
Direction = In/Out
Description = Blocca e registra tutte le richieste che non corrispondono
Source Address = Any
Destination Address = Any
IP Details = Any

Ciao.

Ciao Sirio,
Non c’è stato bisogno di deflaggare: Block fragmented IP datagrams.

Prima di chiedere aiuto sul forum avevo provato la tua regola 1 che ricavai molto a naso in base alle mie limitate conoscenze…
Proverò in abbinamento alle altre due e ti posto i risultati.

Grazie mille

(:WAV)

Max

Grazie a te Max :-TU aspetto il tuo rapporto… ;D

(:WAV)

Ciao Sirio,
non ho ancora avuto modo di provare le ultime regole ma ho già settato tutto e alla prima occasione ti dico.
Ho lasciato comunque le porte aperte in My port sets (anche per la precedente configurazione) e ho anche lasciato invariata la regola di blocco nelle global rules.
A presto
Max

(:WAV)

Ciao Max,
già che ci sei puoi controllare se mettendo solo Out (in Direction) le regole vanno bene ugualmente.

Le porte in My Port Sets le puoi cancellare visto che non le utilizzi mentre la regola di blocco nel Global Rules rimane invariata.

(:WAV)

Ciao Sirio,
sono finalmente riuscito a fare un po’ di prove: l’ultima configurazione non funziona. Ha lo stesso problema che avevo in origine.
Gli altri vedono me ma io non vedo gli altri. In sostanza il valore di downstream sull’interfaccia di collegamento è =0 mentre quello di upstream rivela un numero variabile in base alla quantità di banda utilizzata.

Naturalmente se rimetto il set di regole precedenti tutto riprende a funzionare perfettamente: sia down che up mostrano l’attività di connessione insieme a un altro parametro User=x per il numero degli utenti connessi.

Rimango a disposizione per ulteriori…
Ancora grazie,
Max
(:WAV)

Grazie a te… almeno ci siamo tolti ogni dubbio.

Alla prossima :slight_smile: