IBM lenovo ThinkVantage button and Volume controls [Resolved]


I have just recently installed Comodo firewall on my laptop however ran into a problem. It would appear that the firewall stopped the volume buttons and the blue ThinkVantage from working.

No alert came up however so there was no way for me to allow the application, any ideas? I have had to uninstall Comodo for now until I get this resolved.

Thanks in advance.


Hi and welcome to the forums,

Can you give us some more detail about your system (e.g. OS, software, etc) as well as what version of Comodo firewall you had installed?



Thanks for the reply.

System is a lenovo R60 laptop running Windows XP. The version installed was the latest version on the website (

The laptop has 4 buttons above the keyboard, three for Volume (Mute/Down/Up) and a blue ThinkVantage button whihc launches a IBM tools program.

With COmodo installed these buttons do not work, however I do not get a prompt from Comodo saying that a application is trying to perform an activity so I can not allow the application.

The firewall was in learn mode for applications, however I turned everthing off in Comodo and it still had the same problem. Uninstalled Comodo and everthing is now working again.



Since at this point you have uninstalled Comodo, I would recommend (provided you’re willing to try it…) that you look at the install tutorial video, here:,4766.0.html, then reinstall. Your basic steps will be to install on Automatic, run the Application Wizard, and reboot. It is possible you might still need a rule to allow your programmed keys; CPF may be blocking the system’s HID process from localhost communication.

In that event, go to Security/Advanced/Miscellaneous, uncheck the box for “Do not show alerts for applications certified by Comodo”, check both boxes for “Skip loopback…TCP/UDP”, and move the Alert Frequency slider to High; click OK. Reboot, to clear out the internal memory and set the new controlset. This will obviously give you more popups, but you should see more about what’s going on, and have the opportunity to Allow with Remember to create the rule for your buttons (the only question would be, exactly what those programmed keys would show up as, as far as application…).

You can also check Activity/Logs to see if anything is being blocked, by what and how…

Hope that helps,


Thank you for the advice, I have just reinstalled and followed the advice and it is working wonderfully now (after enabling all my programs again).

Thanks for all the help.


Great, Lee, I’m glad to hear it! (:CLP)

We’ll mark this closed for others’ benefit…