I want to give up on CIS, so annoying !

Everytime I play a game it stalls because CIS pop up a window in the background which I cannot see.
I cannot get out of the game with ALT+Tab.
In previous versions I never had this problem. Why is that ?
This need to be fixed very soon.
This doesn´t help in many cases too !!! :
https://forums.comodo.com/firewall-faq-cis/game-or-video-stalls-in-full-screen-mode-t77620.0.html;msg555138#msg555138

Please fix this very soon !

THX

I am sorry you ae having this problem.

Please ensure you put both D+ and the firewall into training mode.

Also please run in training mode for the ful duration of a game and its closure before switching to safe mode

If this does not fix the problem, please post your D+ and firewall logs, and your active process list, in both cases taking during the process of running the game, and we will try to determine what’s wrong.

Best wishes

Mouse

I would avoid training mode by any cost, ESPECIALLY for firewall!
Here is a rule set, which most probably is “more strict” than what you would get with trainings mode, but its you who gives this rule for a file, and even steam games will run without black screen:
Make your own predefined policy for defense+, call it “games”:
Allow everything in that rule set, BUT KEEP these ON ASK:

  • Start other processes
  • End other processes
  • Install system drivers
  • Ram (Working memory)
  • Hard drives
    If you want to make a rule for “offline games” seperately, keep “DNS RPS service” on ask too.

A firewall predefined rule named “games” would include only:
TCP+UDP OUTgoing.

Thats it.

I gave up to ask (a wall) if comodo can make such a rule for gamers.
And made my own rule. Have no idea why they rather expect you to use trainings mode (valid for all virus which might be on your computer in the same moment), than to make a game rule like this.
Its you who can decide what is a game, and what not.
Hope that helps.

Does game mode still cause issues?
I’ve run a game for 5 minutes in training mode, ended the game, and placed CIS back in Safe mode with no issues seen later.

The thing is, you ran your whole COMPUTER in trainings mode with trainings mode. And look in your rule set for “what rule this game got”:
You will see, it got more privileges than my rules set would give.
Trainings mode gives blue prints of “allow all”, for everything which is asking while running in that mode…

This is true. But I presuppose during this run anything running I want running for the game to work. After switching back to Safe Mode anything else that might want to run will be effectively blocked.

Try my rule; no more presuppose :wink:

And compare the rules (trainings mode created OR the own predefined rule) regarding to the level of “strict”.
What is the benefit of not having such a game rule?
I ask myself for years.

I’ve had this happen as well, even in Game Mode…Seems that the pc gets stuck when you try to alt + tab out and you just view a black screen for a few minutes and sometimes the pop-up will disappear before I can view what it was for…it usually a sandbox pop-up about unknown or firewall pop-up to allow the IP.

Happened when I played Diablo 2, World of Warcraft Cataclysm, Starcraft 2, GuildWars, and Everquest…I just went into the settings and added each games .exe to allow IP needed to connect and no problems

What I don´t understand is why in previous versions of CIS this never happened, why now ?
Before the game just went to the taskbar and I could could see the CIS pop up, now not.
Training mode is no option as for obvious reasons like the ones before this post.

Some games freeze, very few dont. It has been like that long ago. Thats why i made my rule.
Since i use it, i dont have to care :smiley:

try game mode

Hi Clockwork

JUst trying to fully understand what is happening here.

To help me understand your solution, could you tell me what your base CIS settings are.

Are you running in paranoid mode or safe mode in D+ and F/W?

Are you using the auto-sandbox in D+, that is what are your execution control settings?

Finally it seems to me that your solution must be giving prior access rights that are greater than game mode, which I think blocks some requests but allows others. Game mode also auto-sandboxes, which may explain some people’s problems. (For sandboxed executables I suppose it blocks some residual alerts and allows others). I’m guessing your approach runs with the sandbox disabled, as I think that the sandbox would otherwise over-ride it.

I’m also guessing some people have problems with the training mode solution because files are being sandboxed, which would over-ride training mode allow rule creation.

Many thanks

Mouse

I tested as long until steam games worked. (One time you might get a freeze though when the game overlay is started the first time, naturally while a game is allready running. But after steam is allowed to start the overlay, you will not have any freezes. Its just not smart to make a “allow to start other programs”-rule in the own predefined rule, just to cover a singular happening.)
When these games work with game mode, this mode provides simillar rights for them.
But game mode demands switching on and off. And it is valid for the whole machine!

And trainings mode gives permanent blueprints of “allow all” (apart from start another application), for everything running at that time. Try it yourself.

It was born under paranoid mode :smiley:
Defense+.
Is valid for safe mode too.

I suggest to use the firewall in custom mode. “Allow game UDP+TCP OUTgoing only” is allowing to play 99,5% of the games online.

Basic cis setting is “proactive”. Highest settings usually.
Sandbox is disabled.
If my suggestions are not valid for sandboxed useage, let me know. I will then include a notification about this.

Yes I can see this would be true.

When these games work with game mode, this mode provides similar rights for them.

But game mode demands switching on and off. And it is valid for the whole machine!

And trainings mode gives permanent blueprints of “allow all” (apart from start another application), for everything running at that time. Try it yourself.


Yes that is what I thought

It was born under paranoid mode :D Defense+. Is valid for safe mode too.

I suggest to use the firewall in custom mode. “Allow game UDP+TCP OUTgoing only” is allowing to play 99,5% of the games online.

Basic cis setting is “proactive”. Highest settings usually.
Sandbox is disabled.
If my suggestions are not valid for sandboxed useage, let me know. I will then include a notification about this.

OK will need to check situation where sandbox is enabled, next week probably unless you do before.

Trusted files will be allowed outgoing FW access anyway. Untrusted files will not be allowed I think, though I am unsure whether FW rules or mode can over-ride sandbox policy, think not but would need to check. Of course we now have ‘do not show pop-up alerts’ setting to consider as well.

I hope the sandbox override firewall “feature” is not present anymore.

My suggestions are based on the opinion:
If you make the rules in the right way, you dont get annoyed while being safe, so you dont need to use “userfriendly” features which lower the security.
With this philosophy you can be happy with (HIPS) paranoid mode! :wink: … Safe mode anyway.
And,
a firewall should be on custom mode. To give the user the control.
Its easier to write a manual about basic rule routine,
than to write routines into a program which are meant to “safely keep” people away from learning how easy these rules are :smiley:

I’m thinking that your technique is only needed by people running in paranoid mode.

@CLockwork

Just trying to work out whether this technique or some modification of it, will help people run games in Safe mode.

If you run in Safe mode and make the game files safe, then the permissions you grant in your policies will be granted anyway, I think?

Some people do seems to have trouble with games (defined as trusted files) in safe mode, WOW used to be one, but maybe no longer. I’m guessing that these same games would cause problems when using your technique?

Anyone any thoughts about this?

Anyone know any games that still don’t run properly in safe mode under default settings?

Best wishes

Mouse