I want to be solved incompatibility of Comodo Internet Security and Elantech

For almost a year trying to find solution to this problem. I tried to add the exception Etdctrl.exe process, but all options were about the same results, once you use special functions of the touchpad, the etdctrl.exe up and remained at 50% CPU usage, even if an exception was added to the defense + I tried to disable all functions of Comodo Internet Security, but nothing etdctrl.exe the climb again to 50%, drop to 0-1% only when I open the Comodo Internet Security main window. And no, the process is not to blame, because the avast free 6 together with the firewall Windows 7 Professional 32 bit SP1 everything goes absolutely normal, I think the problem is strictly between Comodo and Elantech. Otherwise I can not explain why other security products I have no such problems. The same problem is repeated in CIS 5.4 up to version CIS 5.9. I hope that in future Change Log to contain the problem solved of users using notebooks with windows 7 and tochpad Elantech.
As additional information I use Elantech driver Version V8.0.5.1:

http://support.asus.com/download.aspx?SLanguage=en&m=K53U&p=3&s=295&os=29&hashedid=k6rNoNTFRn0y8jcp

                                                                                                                  Thanks Comodo.

Hi,

Can you verify if you have entries on the Defense+ Log I suspect it’s trying to access cfp.exe which isn’t allowed to access it’s memory.
I have seen this happen with process explorer from Sysinternals also.

Yes it is, appears in the list of blocked objects, and tries to access memory. But if added to the exception, why Comodo block it?

To prevent other applications from attacking the memory of cfp.exe
If you trust the application that cfp is defending it self from you can safely add it to the exception.

In this case the error is on the driver of the touchpad, it should give up accessing the memory if it’s denied for longer then x attempts to open it.
Because it doesn’t stop attempting to open the process memory space the CPU goes high.

Ok. If the solution by adding the exception does not work. What remains to be done? I tried another newer version of Elantech, but the same. Comodo can solve this problem through an update?

Nope, the issue lies in the way the Elantech driver keeps trying to read the memory which it isn’t allowed to access, it should stop doing that after like 3 requests.

Translation: Contact the driver manufacturer about the bug in their driver and hope they fix it.

Ronny just too polite to say it that way :?)
but armed with the information you have gleaned from this exchange you can now file a full and detailed bug report with the company who provides the driver software