I tried and tried, and could not get Comodo IS to run

I have tried to install comodo on my machine, after installation and update of the virus DB, it asks for a restart… and then it just does not work, Comodo wont run on start up and even if I attempt to run it from the programs menu it just does not run.

another side effect I noticed after installation is that my internet connection does not work too!
If I try using the uninstall in the programs menu it does not uninstall, I have to do this through the control panel…

The funny thing is I installed comodo on my laptop too and that works just fine!

I really cannot figure out what to do, I tried searching for threads on this forum that could help me out, bu I could not find anyone with the same problem as mine…

Someone please help!!

Do you have other security programs running in the background? Try disabling them and see what happens. Does this help?

You can use this clean up tool (made for XP but will partially do the job on Vista/Win7 as well) for making a clean install. Also consider the following.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are noauto starts from your previous security programs download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Now you can try a clean install again.

Wow, thats quite a bit of doing, thanks for your detailed instructions, I will try this and see what happens… I will come back … thanks so much for your time.

Nice, comprehensive answer Eric. Good job mate!

It is one of my notes kept in my Opera browser… Try Opera one day… :wink:

Some standard answers I put to my Notes and hone them a bit to make them easily deployable.

Ok, here is what I did…

I used the Device Manager procedure you mentioned and found “partizan” in the list of non plug and play devices… this is part of RegRun that I used earlier… I thought I had it nailed… but again after cleaning that up and doing a complete install and painfull signature DB update, I ended up with the same problem again.

Then I went back and uninstalled CIS from control panel and went back to make sure all files and folders were deleted from Program files and Application Data folders. while I was at it, I noticed there was a folder of RegRun in left behind in the Program Files area, so I deleted that too!

Now Im going to try the whole thing all over again and see if it works…

Im scared to use the Autorun program because of the Dangers you mention, and Im not an OS Junkie :slight_smile: who keeps experimenting with stuff, so if something did go wrong I would not know what to do.

and thats it, I tried again, and it dint work… the funny thing, I had the same program installed on my laptop and it works just fine, the laptop too had RegRun installed before, and I just did a plain uninstall…
and it worked, I didnt have to do anything out of the ordinary.

I dont know what could be a solution. :frowning:

Just to be certain - you are installing this from an adminstrator or equivalent login account, aren’t you?