I thought I had it fixed...but...

Turns out my issue isn’t fixed at all… it’s a problem w/Defense +.
When I enable it, explorer.exe wont run…neither will half of the others…

I discovered this when I noticed that my firewall had blocked 0 attempts over the period of about a week (last version of CFP3 was showing 200-300 daily) and decided that I might need to tighten the reigns a bit to see what happened.

When I reboot with Defense + enabled my desktop is gone again - after disabling in safe mode and rebooting my desktop is back

Do I need to reinstall, or is there something I’m missing?

I’ll give you a thousand dollars if you help me…

Yes, I installed as basic firewall only.
Yes, I have searched for a fix…there’s even a reference on Yahoo answers, though not a particularly helpful one. I was looking at this:


…and it looks like I’m not really in a unique position here.

Well it’s hard to judge your problem at first, but I’ll tell you my D+ settings, I also have XP SP2. First of all my D+ is in clean pc mode and “D+ > Advanced > image execution control settings” in normal, everything as default.

Explorer.exe and others are in the “windows system applications” file group; sorry I can’t tell you how many were by default and how many were added by me (perhaps explorer.exe was one of them), but in the process of building the group from the default I didn’t experience problems like you just popups. In “D+ > advanced > computer security policy” the “windows system applications” file group has the predefined “windows system applications” policy assigned, this is obviously the default, but anyway the homonym file group and predefined policy are different entities despite of the name and if your WSA group does not have enough permissions you should change that.

Another problem might be Comodo protecting itself too much, but the default configuration also provides for that. In “computer security policy” the “protection settings” against inter-process memory access and termination for the “COMODO Firewall Pro” file group may be enabled, but then the WSA file group should be excluded from that protection (clicking on “Modify…”).

Well maybe I could go on but this is the essential part. If this doesn't help, of course you could try uninstalling and reinstalling, since you've had to get your hands dirty already, :-\ reinstalling should help or else your problem would be quite particular (not saying that you'd be the only one). Download the latest version from www.comodo.com. Uninstall, and to make sure there are not leftovers of the rules delete the registry folder "HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\" if still existing. Then reboot, first disable any real-time protection programs you may have (AV etc. this is important, you may want to use even Windows' safe mode to be sure), install, and do it with all the recommended default settings, including activating D+ but in "clean PC mode". If you make D+ work without causing problems then you may start moving towards customizing it but for starters leave everything at default.

Hot ■■■■, that is one thorough response…much obliged :■■■■.

I originally tried to enable Defense + in “clean pc” and that’s when my 'puter took half a poop…which is technical jargon for “wouldn’t fully start”.

My girlfriend says I’m not allowed to “break the g&d d&mmed thing again” until she is finished with the apps she has open, which could be sometime this fall. (:LOV)

I will attempt these configurations and report back when I am allowed to…sorry guys.

Thanx again J

You’re welcome Comofo. :slight_smile: I’ll leave the thread open, feel free to post back whenever you wish. Also anyone with a similar problem.

Now that the turmoil about the upgrade is somewhat past and the biggest bugs were fixed, it’s important for us to discriminate what problems are caused by real bugs or at least conflicts with other programs, and what by an unfortunate configuration which is easy if people get trigger-happy, you know what I mean. :slight_smile:

By the way I forgot to mention, although it was implied in my recommendation to leave everything at default when installing. I think, not sure right now about the exact thing, that the installer asks you if it should scan your computer to build a database of your already installed software and define it safe when in clean pc mode. As with everything else, do so (otherwise the clean pc mode just wouldn’t work…) as default, and also as default “trust apps signed by trusted software vendors”… etc. etc. etc. Sorry to sound like a nanny. :stuck_out_tongue:

You gotta listen to your woman pal. “Like the wind that covers our land, strong enough to rule the heart of every man, this thing called love.” :wink:

Well dip me in sh…you was right. (:CLP)

Took a look and sure enough explorer was not in there, neither were a few crutial others.
Made some changes and gonna try it again…if I’m not back in half an hour, send for someone…

Okay but I think it was me who added explorer.exe to that file group, and you can always define the exact permissions for it alone, with the default setting you shouldn’t experience problems, even though you see popups from explorer.exe and others.

Well, I finally sorted it out…to the best of my ability.
I did a reinstall and import, along with the p2p rules, configurations, etc.
As much as I genuinely appreciate Comodo’s free products I must say:

If time is money, then I just earned my firewall.

These guys might have the most effective free firewall available, but it ain’t for sissies.

Thanks for your assist J

You’re welcome C. :slight_smile: Perhaps I’d better have warned you from the beginning that it was likely easier reinstalling as default that hunting down all the current conflictive settings… Glad it’s finally working.

ok, looks like I have another obstacle (I’ve spent every spare minute for the last week on this thing).
I keep getting these blocks that appear to be from my ip to my static? They look like this:

…and I’m getting 3000 per day. Please advise, I’m in the home stretch here.

I also have to say, I had the last version of CFP 3 (275?) set up just fine. It took me literally months of training the thing to accept and commingle with all of my apps, etc…but it was set perfect.

Then I get home one day and it says “new version available” and fearing that updates/support for my then current firewall would cease, I capitulated.

Ever since I’ve been at my desk working on a solution for this version. I’m not ditching it, I’ve invested too much time now and I know it’s too effective a product to throw out with the proverbial bathwater.

It does occur to me though that the other version was just fine, if not significantly smoother.


To be honest the networking stuff is my weakest point. But there’s a lot on that kind of traffic in this thread:

Windows Operating System / System Idle Process in Logs

I get a lot of those from many remote IPs, I myself just disabled logging for unsolicited inbound attempts. :stuck_out_tongue:

I’m not sure I remember exactly the versions released to date… I know the very first one had some ugly bugs, although it worked fine for most people including me, that’s why no beta tester had come across the bugs. Then a new beta was made available on demand on an individual basis, and finally a new version was released that fixed the bugs (this is the one that started to call “winodws operating system” what previous versions called “system idle process”. Although I had experienced no problems myself I chose to uninstall and reinstall at this point and start from scratch, but it learned all right. I think CFP updated once more normally, but my rules remained fine and I experienced no problems.