I Need To Open Port 3392 In Comodo Free Firewall

When I travel out of town I use my Windows laptop to remote access into my Windows desktop at home which uses Comodo free firewall.

Yesterday I quit using an old Gateway PC at home running Windows 7 Professional that I figured out how open port 3392 when using Comodo Free Firewall version 4 a couple of years ago. The old Gateway PC is now running Comodo free firewall version 7 due to upgrades since version 4.

Yesterday I quit using the Gateway PC and now I am using a Dell PC running Windows 7 Professional. This afternoon I installed Comodo free firewall version 8. Since this version has a much different user interface than version 4 that I figured out how to open port 3392 I don’t know how to do that in version 8.

Can someone please tell me in version 8 how to open (or add) port 3392 so I am able to remotely connect to the new Dell PC?

Thanks very much for your help. Bill

Are you using Windows Remote Desktop or some other solution?

I am using a Macbook Pro laptop with an application called Jump Desktop as my remote access software. I have the Windows PC Remote Desktop configured correctly. I just don’t know how open Port 3392 in Comodo Free Firewall version 8.

I also have two additional Windows 7 Professional machines that are running Comodo Free Firewall version 8. Those two machines are also setup for remote access and I am able to log into to them remotely from my Macbook Pro so those ports are setup correctly from the previous version 4.

Can you tell me how to open Port 3392 on Comodo Free Firewall version 8?

Thanks very much for your help. Bill

You need to click the green arrow in the top left corner. Firewall Tasks → Open Advanced Settings

Once there on the left hand navigation click Global Rules, then Add a new rule.

Action: Allow
Protocol: TCP or UDP
Direction: In
Source Port: 3389

I’m guessing at the protocol since the lack of clarity in the jump desktop setup information on their support site only shows checking a few boxes on windows firewall. They don’t even mention the port number.

Next create an application rule for the jump desktop process and set it to ‘Allowed Application’.

When adding a Global Rule, you say to use Source Port 3389. If I am trying to open port 3392 on the new PC wouldn’t I use Destination Port 3392?

My remote access software, Jump Desktop is installed on my Macbook Pro laptop - it is not installed on the Windows PC that is running Comodo. When I try to create the Application Rule it appears that Comodo wants me to browse to the Jump Desktop file which is not on my PC. If I “Use Ruleset” there is a Web browser dropdown. I am confused on exactly how to create the application rule.

The old PC with Comodo version 7 is setup correctly to accept remote access for port 3392. Is there some way I can copy the settings from the old PC over to Comodo on the new PC?


No because the RDP process has to listen for incoming traffic. The ‘Remote’ is then actually a server. The server doesn’t actually send any traffic out until it receives something so it doesn’t have a ‘destination’, instead it has a mailbox (source port) where packages are dropped off for it to handle.

This is where I guess I assumed wrong that the Jump Desktop software was installed on both the client and the remote. Would I be correct in assuming that Jump Desktop talks directly to the built in Windows RDP client? If thats the case then you need that global rule and an application rule for C:\Windows\System32\mstsc.exe, and possibly rules for svchost.exe.

I suppose its possible, but there have been previous issues where old configurations do not import correctly on major revisions changes so I wouldn’t recommend it. Is there any chance you can recreate the rules manually?

Aim4it -

Thank you very much for the help you are giving me, I really appreciate it.

I would like to start over with my explanation of what I am trying to do.

I have 3 Windows 7 Professional PC’s all hard wired networked together. I am using Jump Desktop software that is installed on my Macbook Pro laptop to remotely login to the 3 Windows PC’s at my house when I am out of town. I have Windows Remote Desktop (RDP) configured on each of the Windows PC’s.

When I initially set up the remote desktop access to the PC’s several years ago I learned that I needed to port forward three ports (one for each PC) through my AT&T router. I assigned a different port number to each Windows PC and successfully port forwarded each one through the AT&T router. I did all of this several years ago when I was using a much older version of Comodo Free Firewall. Now I am using Comodo Free Firewall version 8 and the user interface looks significantly different than the older version. I can successfully remote access using the Jump Desktop software on the Macbook Pro into two of the three PC’s. In Comodo Firewall for the two PC’s the only entry I can find in the Advanced Settings > Firewall is in the Portsets. Under the HTTP Ports there is a port 3391 which is one of the forwarded ports for one of the PC’s. There are no Application Rules, Global Rules or Rulesets, only the 3391 value for the HTTP Portset.

The PC that I am having trouble configuring with Comodo uses forwarded port 3392. When I create a Portset for HTTP Ports 3392 like has been done in Comodo for the other two PC’s, I am not able to connect with the Macbook Pro and the Jump Desktop software. The windows says Connecting but it never connects.

Does this additional explanation help to understand what I am trying to do?

Thanks again for all of your help and for your time.


Creating a portset alone doesn’t do anything. Its just a logical grouping of port numbers. You need to use it in a rule.

I have fixed my issue of opening Port 3392 in Comodo Firewall. I located the notes I created 4 years ago when I setup my three PC’s for Remote Desktop Login.

In the new PC that I was having trouble with, in the Windows Registry I changed the Remote Desktop Listening port from 3389 to port 3392 which is assigned to new PC and port forwarded in my router. I then added port 3392 to the HTTP Portset. I am now able to remotely login using the Jump Desktop software installed on my Macbook Pro.

aim4it, thanks again for all of your help and your time. I really appreciate it. Hope you have a Merry Christmas and a Happy New Year.