I had to reinstall Windows, forget my firewall settings.

I had my firewall set so Comodo would ask me anytime a program wanted to connect outbound but I don’t have it seem to have it set that way.

I thought it was supposed to be in Training mode?

Firewall - training mode
auto sandbox - disabled
HIPS - training mode

is there something else I’m missing here?

Thanks in advance.

Training mode will allow all alerts and create an allow rule for anything run. You will need to change the firewall to custom policy. This will alert you for any Internet attempt if a rule is not present.

Before you switch modes go through your rules and delete the allow rules that training mode created.