I Fail dnstester.exe

Hi On Win XPPro SP2 I passed these LeakTests

Wall Breaker
CPIL Suite

But failed DNStester, answering Block this request.
My Firewall 3.015.277 is set to Train with safe mode/Train with safe mode
I originally had a Defence+ of Clean PC Mode and i had to reinstall all my Leaktests before Comodo would stop them.
Any ideas on how to stop DNStester too.
My DNS client windows service is enabled.


I just tried the test myself (changed to Train with Safe Mode/Train with Safe Mode and turned on DNS Client) and here’s the popups:


By answering Block to all of them, I suceeded the test.


I only get the top left warning an the bottom right warning.
Then Dnstester says I have failed.

As most .exe have the same rule in Network Security Policy.
I made a Executables Rule that was giving Dnstester access to the internet.
I removed the rule.
I now get the top left warning, the top right warning and the bottom right warning.
The Dnstester says I have passed.

I’d like to know more about this problem. I failed it too, and did a clean reinstall, and put D+ and FW in Train with safe mode. I always fail the DND tester. I disabled the DNS client, and then I only get 1 warning about DNS Tester wanting to connect to Internet via DNS port. If I allow that one and single warning, I fail the test. I’m behind a router-modem (I tried inside and outside the DMZ).
I’m using version 277, 64-bit version, on Ultimate x64.
What can I do? Most of the other leak tests I have no problems…

I have a similar response as Ragwing (CPF 2.4 for windows 2000, also behind a modem-router).

But, let’s be realistic: what is the use of a firewall if one allows some communication he’s supposed to know as rotten? (in the same register, i fail every of CPIL tests…because i systematically deny IE).

In no real circumstance a right-minded person would allow any communication on port 53 for an application he doesn’t know anything about (and even for one he knows; i denied, when downloading pdf files, the rights of Acrobat (full, not reader) for port 53: the job was just to allow the browser to view and download a file, and i do not remember i did ask acrobat to “communicate” anything while doing the job)

Makes sense, but the only reason I got a warning is because I disabled DNS client. So I fear I’m not protected like I should and maybe I will not get warnings for unlegitimate applications trying their way through DNS port. So any idea what could be wrong with my installation or rules that prevent the firewall from reacting like it should?

Delete all rules for DNDtester in Firewall and D+
Delete your firewall tests an reinstall them.
If on your disk when you install CFP they are considered safe in default D+ clean mode.
Try with DNS client enabled.

(:AGY) I still fail it, it goes right through with DNS enabled, there are no rules about DNS tester in Network and D+ security policy… Is it a bug with x64 version or there’s a stupid setting somewhere that I can’t think about?