I do not want Yahoo as my start page -- how to prevent this?

A while back, Google incorporated the Yahoo search engine, and now every time I launch
Dragon it opens with Yahoo.com. I do not want to open with Yahoo, I rarely use Yahoo and I want it removed from my Dragon startup options, but no matter how many times I go to Settings and remove yahoo, replacing it with urls of my choice, it always reverts back to Yahoo next time I launch Dragon.
This has become so irritating that I’m just about ready to delete Comodo Dragon from my pc if I can’t use it without that blasted Yahoo interfering all the time. Has anyone found a workaround for this? As I said, changing the settings doesn’t work, yahoo keeps coming back like a bad horror movie. What else can I try to eliminate yahoo from my dragon browser?
FYI I also use google chrome, and it’s browser settings have remained as I want them, Yahoo doesn’t intrude there, only on dragon.

I’m using dragon too but I don’t have this problem.

When you are changing the settings, is Dragon running in the sandbox? If so, run it outside the sandbox and do the changes you want to make and then you can run it inside the sandbox again if you want.

If the above doesn’t work, have you tried re-installing and during the installation unticked that you want to use yahoo? If not you can try that.

There have been lots of posts about the partnership between Comodo and Yahoo, a quick search will find them but here’s a few:

Yahoo redirection after Comodo update
Yahoo Search Engine Removal from my Computer
CIS Upgrade set Homepage to Yahoo anyway

Hi ronc2vn,
What you are describing sounds similar to an issue that was in a past release.
Are you running the current version?
If no, please try the current version.
Comodo Dragon Version 23.4
Thanks.

Yes, that’s one of the first things I checked, and I do have the latest version.
I’ve temporarily fixed the problem by setting my start page to open on a new tab, but that’s not entirely satisfactory. I want my browser’s start page to be a page of MY >:( choice, and definitely NOT any Yahoo page.
I don’t mind that Yahoo exists, it has it’s uses, but I strongly resent and object to the way Yahoo continually takes over my web browser despite my efforts to stop that behavior. Yahoo not only takes over the start page, it deletes any other page I may have chosen to have for a start page, and this interference with my freedom to view – or NOT view – pages of my choice is creating a great deal of distrust and resentment toward Yahoo for doing this, and toward Comodo for allowing it. If somebody doesn’t wake up soon to the fact that many users are feeling this resentment and make some changes, I will drop Comodo entirely and go with a browser that permits me to configure it in the way that best suits me. This is my personal computer and nobody has the right to usurp my settings and preferences for their own commercial purposes. Yahoo should advertise honestly, not by trickery and subterfuge. Yahoo, you are now a big Zero in my book, and Comodo, you seem to be heading that way as well.

As a temporary workaround you can go to “C:\Users\Your Username\AppData\Local\Comodo\Dragon\User Data\Default” and locate “Preferences” Open this with a program like notepad++ or any other program that can open the files.

On line 17 to 21 you should be able to edit to what you want to set. If it still rolls back to yahoo after changing that, you can redo the changes then write protect the file, if you do this then no changes you do in comodo will stick so you’ll have to remove write protection.

Edit: In fact I suggest you search for “Yahoo” in that file since it occurs somewhere at the bottom too!

This issue should not be present in the current version.
Not forgetting SanyaIVs suggestion.
I would consider trying a new user profile.
Or a complete new re-install with a new user profile.
To create a new user profile in Comodo Dragon

This issue is still present in current release and none of advice dosn’t work for me including edit of Preferences file and create new user profile.
Dragon build is 24.2.0.0, Windows XP SP3.

Hi and welcome tomlechat,
Just to clarify where the issue is happening.
Is it your start-up page reverting back to yahoo?
Is it your home page reverting back to yahoo?
Is it your search results from the address bar still using yahoo search?
Thanks.

Hi there! Sorry maybe i don’t understand you clearly coz of my uglish…
If belive to Preferences file

      "homepage": "http://ru.yahoo.com/?fr=fpc-comodo",
      "homepage_is_newtabpage": false,
      "session": {
         "restore_on_startup": 1,
         "urls_to_restore_on_startup": [ "dragon://newtab/" ]

this is my startup page revert back to yahoo.
All references of yahoo in setting is removed or disabled.
When i close Drsgon with only one open tabs so i think it’s crushed or something like this.
Removing manualy yahoo from Preferences file bring it back right away from open Dragon.
Well… that’s what i have.

Hi tomlechat,
If I am understanding the issue correctly, this could possibly be something corrupt with the Preferences file.

Note: The following will remove your current setting preferences.
With Dragon closed I would consider one last try at renaming or deleting your Preferences file from C:\Users\Username\AppData\Local\Comodo\Dragon\User Data\Default folder, re-opening Dragon will recreate this file then change your settings to your preference following the instructions below.
Setting up your Homepage in Comodo Dragon
Opening Preset Pages on Startup
Setting Default Search Engine

Thank you but i have same issue still. Non of manipulations is helped. Including recreate Preference also as whole profile. I see yahoo page in anyway but it’s won’t present in settings at all. Well… i think i must wait for new release of comodo.

I had kind of similar prob with CD, the yahoo thing you have mentioned & all the settings were not saved.

On my system user account folder had become unaccessible & this was the prob.

DEV said “current user doesn’t have write access rights on the user profile folder.”

I solved my user account folder unaccessible prob by taking ownership & adding permissions thereby making it accessible.

Now all the CD probs on my system is solved.

This was on Win 7 64.

I dont know if this will help or not

Here is the link to the thread

https://forums.comodo.com/help-cd/comodo-dragon-prob-t90899.0.html

Hi tomlechat,
Sorry this issue is still persistent.
The only other thing I can suggest is to try the portable version and see if that can save your settings.
Use the same installer, but select the portable version during install.
Portable version instructions
Edit: Almost simultaneous posting Naren. :wink:

Ok well if you had read the installation options carefully then there is clearly an option to uncheck the yahoo.
Ive never come across the problem your describing and its your fault for installing yahoo as you most likely just clicked through the installation without reading etc.

All you need to do is change the homepage internally in the browser to any you choose.
Its not such a big deal to do.

ronc2vn,

in Settings,

just delete all entries in On Startup > Open a specific page > set page (right click-delete did it for me).

Then scroll down to Appearance > Show Home button > Change, and update it to Google.