I disabled all scheduled scans, and Comodo still scans whole computer, why?

From time to time I can see my HDDs working at 100% utilization. If I check what is using it - it’s Comodo Internet Security. Every HDD is being checked. Why is this happening if I disabled all scheduled scans?

I only want to run manual scans never automatic. How do I set this up?

How do I stop these automatic scans that are already running?

Can you check with the Task Manager from CIS if a task is running and what CIS process is active when this happens?

I sort of have this question as well. It seems like after I boot up my laptop and the AV definitions update, the majority of my system is scanned for about 10-15 minutes. The CAVWP process stays at “11%” CPU utilization during this period. 100% / 8 HT threads = 12.5% per thread, so 11% is ~88% single HT thread usage.

Nothing in CIS ever reports that it’s doing this, but my CPU fan and slow responsiveness for other programs makes it obvious every day.

Attached is a screenshot of the CIS Taskmanager and to the left is Process Hacker with the Disk tab open, showing all of the files being systematically scanned.

Could it be you’re witnessing the av scanning updating process of your Steam Apps?

Can you check with resource monitor (resmon.exe) to see if there is writing activity in the Steam Apps folders when cavwp.exe is active?

No, Steam does not auto-run on my system and was not run on this bootup. This is merely the place that the scan was active in. 5 minutes prior it was looking at some of my work applications and before that Visual Studio in Program Files.

The Process Hacker screen is near identical to resmon. It just happened to be what I used because it is always active. The view you are seeing is sorted by bytes read/written per update. No other application even appears that high up in the list because no other application has the disk impact that cavwp had.

Do you have an indexing program that runs in the background? That could explain why you see cavwp.exe scan files on your drive.

My best guess is that, for me, it is related to CompatTelRunner.

Part of the Microsoft Windows Customer Experience Program, it has several scheduled tasks where it skims over installed executables. Unfortunately this “skimming” causes the AV process to deep scan everything it comes across. So while CompatTelRunner doesn’t cause a lot of expended resources(for me), it causes CAV to be curious enough to scan everything.

In this case, it seems easiest to add C:\Windows\System32\CompatTelRunner.exe as an excluded application in CAV. If it’s annoying past that, there are guides on which scheduled tasks to disable to remove most of this skimming behavior. Most would agree that it is unneeded.