I can't Post

Hello friends

I am using FF2 and it is my default browser. After installing Comodo Personal Firewall Pro [the latest version] I can not post in any of the forums any more. :frowning:

I am either being taken to the log in page or I am getting a “Error 400” and the following massege:

Bad Request Your browser sent a request that this server could not understand.

The request line contained invalid characters following the protocol string.

Apache/1.3.37 Server at www.techsupportforum.com Port 80

Can any one please help me out? I use NOD32 as my Anti Virus.

Though I can browse, but can not enter any type data like yahoo Mail! login page can’t be accessed.

Please help.

Thank you.

Are you sure you didn’t disable javascript or use Noscript?
Also, do you block anything? component etc.

You said in your other topic that the error was a 404; here’s some info on that; it will not be a firewall problem, I think. More likely some browser configuration issue.


For the 400 error you mention here,


IF you can indeed post/input data if you turn the firewall off, then you may have some application that ties in with the browser (webfilter, anonymizer, etc) that is being blocked by the firewall and thus the signals you’re sending are being garbled somehow. That’s my only thought, but I really don’t think it’s a firewall issue.


Sorry the error is 400

This trouble came into existence only after Comodo started to operate. Earlier I had ZoneAlarm and there was no problem.

Please advise.

There may be some remnant of ZA left on your machine, in the registry, etc. I would recommend running a registry cleaner (such as RegSeeker) to help clean it out.

You may end up needing to uninstall Comodo FW, clean the registry, then turn off Nod32 & reinstall CFP.

But first just see if cleaning the registry and rebooting helps.


Well thank you for the point.

I remeber that during uninstallation of ZA the whole process stuck and I had to reset the PC get it operational again.

I have used RegSeeker and jv16 Powertools both to clean the entries related with ZA. Still before I get too overjoyed, I would like to see whether I have achieved the solution permanently or not.

Thank you again.


This part as well as the above post I have made using Firefox and I hope that I can continue to do so. BTW, there seems to some issues related with Google Web Accelerator too. Though I know it is bit off topic, still do you haveany idea?

Thank you again.

Okay, we’ll keep our fingers crossed…

As to google web accelerator, you may need to add a rule to the Application Monitor. Under the Miscellaneous tab for that rule, check the box, “skip advanced security checks”, then click OK. See if that helps.


We all know how tough ZA is to kill (look at the termination tests), but how reliable is a manual cleanup with 3rd party registry removal software compared to a program’s own uninstaller? Did you manage to uninstall the official method or was it stuck, reboot, then RegSeeker + Powertools?

http://support.microsoft.com/kb/291793 → This isn’t exactly an answer, just pointing out the potential damage extent of ZA :o
ZA Clean Uninstall

I was a long time user of za free. Before I found comodo I downloaded the latest ver of za and installed. What a mess. It was like my system was dragging a big rock behind it. Tried everything to uninstall even down to a manual registry edit. Still no joy. (:AGY)
Then decided to give it a real kick up the backside, fdisk and format.
ZA gone, problems gone and comodo runs beautifully.
Is there some kind of contest between za and norton to see whose product can hook the deepest?


The contest winner will catch a trout or salmon if the hook is deep enough. Luckily, CFP don’t care for fishies.

src2206, maybe FF is having an issue with being passed from unsecure pages (http://) to secure ones (https://). I googled a bit and found out one user resolved it by deleting ALL cookies. And by ALL I mean for all browsers.

Sorry to hear you had to re-format!Hindsight being 20/20,you could’ve tried this first.Uninstalled ZA.Gone in to “Program Files”.& deleted the ZA file from “Program Files”.Next, go in to system 32,& delete the Zone Labs file.Next.run regedit, & delete any ZA files.I had to do that when I got rid of ZA.Glad I did!.My sister is using Norton AV '07.Nobody’s told her differently,& she doesn’t know any better.

Where were you when I needed you ;D
It was a big job but at the end of the day I have a nice clean system.

My sister is using Norton AV '07.Nobody's told her differently,& she doesn't know any better.

Maybe sometimes it’s better not to know too much :slight_smile:

Sorry I didn’t get to you earlier but there is a nice small command prog to zap ZA remnants
off your system.

Maybe others who are thinking of switching from ZA to Comodo (smart move!) can use it


Glad everything is working OK now

Maybe we need a faq “how to remove za before installing comodo”. :smiley:
There are a lot making the switch now.

Hello Soya

Sorry for being late in replying.

While I tried to uninstall ZA it simply stuck and i had to manually reboot. What I find is that all the registry entrs and some internet rules set by it were left back in the registry [no Sys32 files were there]. So I used RegSeekerand jv16 PowerTools and the trouble seems to gone now.

I also thinnk that you need a sticky on this topic if possible.

Now the only trouble is that my torrent clients are showing block ports…I shall read the stickies available on this and if i can not resolve then will come a new thread. :smiley:

(L) (B) (V)

Thank you again.

Unfortunately, stickies are only for common issues that a lot users share or for temporary news annoucements and that sort of thing.

Since we know it’s not a problem with rules (Allow All failed) and Opera works perfectly, the connection to CFP as the culprit is weak. I’ve seen other reports on google with this error 400 that had nothing to do with CFP, which I know because the forum post about it was dated 2005 (jump search the page for 400).

Have you tried re-installing Firefox?

Other related links:

Hello Soya

Thank you very much for your reply.

I did reinstall FF but that did not help.

One more thing, I believe that there has been a misunderstanding, I never meant that the sticky should be there because CFP is the culprit, rather from the begining I felt strongly that the problem lay somewhere else, and I believe it is the internet rule that ZA created which it did nit clear from the registry or filesystem when uninstalled. So I requested to create a sticky post to make potential CPF user understand that it is not Comodo’s fault, and with a link to the cleaning utility of the ZA. All these to ensure that any new potential user should not feel that it is CPF’s problem and they miss the opertunity to use it.

As I really love CPF asa firewall I would be happy to volunteer if you allow me, just to do some thing in return for Comodo. :slight_smile:


Any blocked Component Monitor items?

Sorry but your question is not clear to me. I understand blocked components but what exactly you want me to find out? :THNK


That means my suggestion was worth nothing :-X.

Do you see any blocked files in your CM list? Maybe it’s related to this. I’m out of ideas. Sorry.