I can't do nslookup inside the virtual desktop (Sandbox).

Hi there community,

I am having a problem with Comodo Virtual Desktop. The problem is that the applications inside the sandbox can’t use or connect to the default dns server for the system.

here is the situation:

Inside the sandbox, I run a cmd (command window) and I can:

ping any dns server on the internet or any ip address on the internet inside the sandbox including (,,,

I can do nslookup against any ip address on the internet that provides dns service, including (,,,

Now how can I use my internal dns service inside the sandbox?
(I can’t really change the global system default dns ip, under no condition. It HAS TO BE

How can I tell the sandbox to allow access to from inside the sandbox?

Is it possible to tell the sandbox, (only the sandbox) to use a different dns server to resolve this, like comodo secure dns?

What OS? And is it specific to opening virtual desktop or does is also happen with any sandboxed application?

It may be by design but for now you can disable filter loopback traffic in firewall advanced settings.

Thank you so much futuretech for taking the time.

I am using Comodo CIS, on windows 10 1607 x64.

Also I have actually thought about disabling “Filter loopback traffic”, but I am afraid I am a very paranoid person, and I really need to know which application is doing what, even internally, including trying to do a simple lookup.

I have also tried to install a dns service indide the virtual desktop (sandbox) but it fails, giving me a message that the service is already installed. Even if I could start a new service running lets say on port 555 instead of default 53, there is no setting in the sandbox to set the default dns ip address.

any ideas folks?

Still no help? :-[ :-[