I can't create global rule for specific IP address

Can someone explain me how can i set a global rule to block a specific IP address? I go to Firewall Settings>Global Rules>Add but it doesn’t allow me to choose any option from the drop down menu, where it says - Type: Any address

You don’t see this (see screenshot) drop-down?

[attachment deleted by admin]

Yes, i am seeing it but whatever option i choose it just stay on Any Address. I am guessing that it should open additional fields under it where i can enter the ip address that i want to block, but this is not happening.

I don’t know what’s wrong then, you could try doing a diagnostics check (Open main CIS Window > Click question mark in upper right corner > Support > Diagnostics) If that doesn’t work then I really don’t know and if someone else doesn’t come with a better idea, I would suggest doing a complete re-install of CIS by following Chiron’s guide.

I run Diagnostics but it didn’t find any errors.
Can you post a screenshot of the Firewall Rule window when you select Host Name or IPv4 Single Address as option?
I have only Comodo Firewall installed but i don’t think this could be the problem. Also using Windows 7 x32.

Screenshot of IPv4 Single Address attached.

[attachment deleted by admin]

Nothing like this is happening on my side, and i even can’t select the IPv4 option.

I recorded a video that shows the problem i am describing: - YouTube

As you have no options even after you select them either CIS is a corrupt install or some other security software is stopping this function.

If it works elsewhere like in application rules then it should work.

Three options change configuration to another as a test, shut down possible uninstall other security software or uninstall/reinstall using the suggest way.

Please note you can export your configuration before uninstall to a non Comodo folder.


It doesn’t work for application rules also and i don’t have other security software installed. I will reinstall Comodo Firewall and see if this will fix the problem.

I reinstalled Comodo Firewall but this didn’t fix the problem. And actually i reinstalled it couple of times, i didn’t know you can run in such troubles reinstalling Comodo. I will not go in details, i will just say that i had to use Live USB and Safe Mode to fix the mess.

Anyway, in the end i manage to make a fresh install of Comodo Firewall and i didn’t import any old configuration, i started making all my setting on a new again. In the beginning i was able to access all firewall rules option, so i thought the problem was fixed, but that was only for awhile. After few moments i did go again to firewall rules window and the problem was there, i was not able to choose any of the options again.

Any other suggestions or i should move to another firewall? For me it’s clear that this problem is related to Comodo Firewall behavior, but i don’t know how to fix it, and if i am not able to set rules, the firewall is pretty much useless to me.

What is happening to you should not happen, so unless you or someone else with the same problem does a bug report with all the required information there is little chance of finding out why.

Sorry without this I cannot suggest anything else as you have already done uninstall/reinstall without importing your old configuration.


Finally i found what was causing the problem, it was a mouse gesture program. I don’t know if the problem is with the program itself, because i am using the program from long time and it didn’t have conflict with other programs. May be Comodo Firewall has some issues with mouse gesture programs.
Any idea what may be causing this, and is there a way to try to fix this from Comodo Firewall settings?

This is the mouse gesture program Just Gestures - We're here to guide you! - Scroll Better. When it is running i am not able to access firewall rules option, when it is not running i can access them.

Most likely Comodo’s self protection is preventing your gestures program form injecting the gesture controls into the Comodo processes.

How to set Comodo self protection to trust JustGesture? I make the program Allowed Application in HIPS Rules options but this didn’t help.

  1. tasks → advanced tasks → open advanced settings
  2. security settings → defense + → HIPS → HIPS rules
  3. double click COMODO Internet Security
  4. protection settings tab
  5. “modify” under the exclusions column in the “Interprocess Memory Accesses” row
  6. add the application you want

NOTE: Doing this will allow the process to kill comodo’s processes in memory so make sure you trust the application you are adding.

[attachment deleted by admin]

I did this: on COMODO Internet Security entry, right click then Edit>Protection settings>Modify>Add>Running Processes and i added JustGesture.exe. But again with no effect. Even if i disable HIPS completely i am still not able to access firewall rules options when the mouse gesture program is running.

Only other thing i can think of to try is excluding the file from shellcode injection in the HIPS settings at the bottom

I did that but no change again. I guess then the problem is with the mouse gesture program though i am using it from long time and i have not noticed to be in conflict with other programs.

Might be time to file a bug report. I don’t see what else could be interfering.