I cannot load web pages when on certain VPN servers. Totally flummoxed!

I’m having the strangest issue and I’m not totally sure if this is related to Comodo Firewall, but I’m definitely running out of options.

Here’s what’s going on:

I use a VPN (via OpenVPN if that makes a difference) provider who offers a lot of choices when it comes to servers all over the world. For the past year or so, I’ve been using their Singapore-based servers. However, two days ago after hopping on the laptop, I noticed that in spite of being connected, I could not load any web pages. I was not immediately receiving any ‘page cannot be displayed’ errors, rather, it looked like a connection was trying to be made, but no data was ever exchanged.

Upon further examination, I could still: check email, FTP (including uploading and downloading at normal speeds), use Trillian and Skype, and thankfully run a tracert in the command prompt which returned normal results.

Logging off and using my naked connection resulted in a normal internet experience. Browsing the web worked as normal.

Here’s where it gets weird: I could log onto other servers by the same VPN provider hosted in other countries and have no issue at all (aside from a higher latency…)! Web browsing along with all other transmission options (FTP, email, etc.) all work fine, but speeds are suffering for distance-reasons.

Furthermore, although I’ve only used one of the five or so servers based in Singapore my VPN provider offers, I’ve tested out the other four servers which I never use and have the same issue of not being able to browse web-sites.

This is mind-bogglingly strange since the issue is so isolated. I first thought it was a DNS issue, but then how come I can browse pages fine off the VPN and on other non-SG servers with the VPN provider? The VPN provider reports no issues with their SG servers and all SG servers are quite active b/w-wise going by their publicly available stats leaving me to believe this is a very isolated incident.

This led me to believe it was an issue with Comodo Firewall. I first tried disabling the firewall, but that didn’t help. Restarting the computer (Win7 64bit Pro Thinkpad) and that didn’t work either.

To summarize, I can’t browse pages on Singapore VPN servers (which are all up and running), but can browse pages when off the VPN and when using other VPN servers. All other internet mediums (FTP, email, etc.) work fine both on-and-off VPN including SG servers.

Do you all think this is a Comodo issue? Or what?

I am running Comodo Firewall 6.2.285401.2860