I cannot get certain programs to run

After I had to pay someone to reinstall Windows XP after my computer caught a NASTY virus, I put Comodo IS on here first thing.

After that I installed Space Rangers 2 (would try to start up but Comodo would ask about a zillion questions), DOSBox (dosbox.exe has encountered a problem and needs to close), and Civ 3 Complete (which runs fine.)

I played Civ 3 for a while, but after buying Sins of a Solar Empire I wanted to install and play that. After installing it, I tried to run it, but it quits after I start it.

I installed Sid Meier’s Pirates (the new one) just now wondering if Sid had somehow put a virus on my computer that allowed only his games to work. :smiley: Instead I get the message “Unable to initialize DirectX.”

Any ideas?
Do I need to uninstall everything and then reinstall it? (briefly considerd, but that takes lots of time.)
Do I need to uninstall and reinstall Comodo? (also considered, but didn’t think that would work.)
Do I need to get a registry cleaner? (Got Uniblue’s RegistryBooster 2009 put on here and it claims there are 106 problems, of which it can fix 15 unless I buy the full version.)

By the way, I am running Windows XP Media Edition with SP2 (SP3 is EVIL!!!), and Defense+ is set to Clean PC mode.

Put Defense+ in “Training Mode”, run the game for a bit then put it back to Clean PC Mode.

P.S. Remove any of the games files from your “My Pending Files” list.


I have (most) always remembered to remove the game files from the “My Pending Files” list. I have forgotten once or twice, but still…

And the Training Mode solution does not seem to work. Everything acts as it always has. Pirates still says “Unable to initize DirectX” I am wondering if I somehow managed to goof up DirectX now, considering that both Sins and Space Rangers use DirectX for graphics.

Strange. I have Sins of a Solar Empire and Training mode worked for me.

Can you show us the D+ logs when starting up the Pirates game? The logs can be found under D+ → Common Tasks → View Defense + Events.

Ok…there is nothing there for the Pirates game. There is the record of me trying Training Mode, and then putting Comodo back into Clean PC mode, but that is the most recent events.

No Pirates, Sins of a Solar Empire, Space Rangers 2…nothing pertaining to those games which are not working.

Lots of stuff concerning RealPlayer though. As well as when I put the DivX Converter and Player on my computer. Might that have something to do with my troubles?

Otherwise I am seriously thinking I need to do something about my DirectX.

It never hurts to install the latest Direct X: Download DirectX 9.29.1974.1 for Windows - Filehippo.com .